summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-11-18 15:55:22 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-11-18 15:55:22 (GMT)
commit4f8ca8e026fbff3eafaf514bb0be8a4126593268 (patch)
tree63f46898d4de94232f09e4c1b1bad77b99508c90 /Makefile.am
parent75ea10e5f50c3c23fd73f073adb84b0baf551edc (diff)
downloadhdf5-4f8ca8e026fbff3eafaf514bb0be8a4126593268.zip
hdf5-4f8ca8e026fbff3eafaf514bb0be8a4126593268.tar.gz
hdf5-4f8ca8e026fbff3eafaf514bb0be8a4126593268.tar.bz2
[svn-r11738] Purpose:
Configure feature Description: Added 'make trace' target. Solution: Added tracing to 1.7. This was done automatically in 1.6, but left out of 1.7 until now (oops!). Tracing in 1.7 only happens manually, when the user types 'make trace.' Tracing automatically requires more framework than it's worth. I also fixed a couple of tracing bugs and ran trace. Platforms tested: mir, sleipnir, modi4 Misc. update:
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ec07fc7..b6c00fe 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -137,6 +137,11 @@ uninstall-doc:
installcheck-local:
@(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+# Only source files in the src directory include tracing information,
+# so 'make trace' only needs to recurse into that directory.
+trace:
+ @(cd src && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+
# Automake wants to make config.status depend on configure. This
# makes sense, but config.status can't always be regenerated
# properly, which can cause builds to fail.