summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2009-04-21 22:46:38 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2009-04-21 22:46:38 (GMT)
commit5bb857476f99118cda0e54ea522f52933a582747 (patch)
tree741024b69250fe9166091aa8f28bc78c35d3fb64 /Makefile.am
parent35bbc743d4cf77d6aa8af2acf5578db02e5129ca (diff)
downloadhdf5-5bb857476f99118cda0e54ea522f52933a582747.zip
hdf5-5bb857476f99118cda0e54ea522f52933a582747.tar.gz
hdf5-5bb857476f99118cda0e54ea522f52933a582747.tar.bz2
[svn-r16825] Description:
Bring revisions 16636:16821 from trunk to revise_chunks branch Tested on: FreeBSD/32 6.3 (duty) Mac OS X/32 10.5.6 (amazon) (h5committest not needed on this branch)
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c0d6827..7acc2db 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,6 +79,9 @@ DIST_SUBDIRS = src test testpar tools . c++ fortran hl perform examples
# Some files generated during configure that should be cleaned
DISTCLEANFILES=config/stamp1 config/stamp2
+# Some files/directories generated during check that should be cleaned
+CHECK_CLEANFILES+=*-tmp
+
# Define rules for lib, progs, check, and tests.
# These simply involve recursing into subdirectories.
test _test: check
@@ -113,6 +116,7 @@ check-clean:
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
fi; \
done
+ $(RM) -rf prefix-tmp destdir-tmp
# Some C++ compilers/linkers will create a directory named ii_files in
# the root directory, which should be cleaned.
@@ -150,6 +154,23 @@ installcheck-local:
# check-install is just a synonym for installcheck
check-install: installcheck
+# check-all-install tests all installation methods.
+# Install via different mechanism and then compare against the default.
+# Fine if only libXXX.a files are different since they may have been ranlib'ed.
+check-all-install:
+ @echo Installing to default location
+ $(MAKE) install
+ @echo Installing to different prefix location
+ $(MAKE) prefix=${ROOT}/prefix-tmp install
+ @echo Compare against the default installation.
+ @echo Fine if only libXXX.a files are different.
+ -diff -r prefix-tmp ${prefix}
+ @echo Installing to different $$\DESTDIR location
+ env DESTDIR=${ROOT}/destdir-tmp $(MAKE) install
+ @echo Compare against the default installation.
+ @echo Fine if only libXXX.a files are different.
+ -diff -r destdir-tmp${prefix} ${prefix}
+
# Only source files in the src directory include tracing information,
# so 'make trace' only needs to recurse into that directory.
trace: