summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2010-09-16 22:12:07 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2010-09-16 22:12:07 (GMT)
commit696675029e4bd3461bc175fb9d9b3406767acbfd (patch)
tree127f396203cf7bfc798ae684818aac5ff40fd46c /Makefile.am
parent6d97ffcc6cec0c23e718da16fcf0f2043df046c5 (diff)
downloadhdf5-696675029e4bd3461bc175fb9d9b3406767acbfd.zip
hdf5-696675029e4bd3461bc175fb9d9b3406767acbfd.tar.gz
hdf5-696675029e4bd3461bc175fb9d9b3406767acbfd.tar.bz2
[svn-r19408] In this revision the '/' after ${DESTDIR} wherever it occurs
has been removed. According to the official description of DESTDIR by Gnu at http://www.gnu.org/prep/standards/html_node/DESTDIR.html, DESTDIR is prepended to the normal and complete install path that it precedes for the purpose of installing in a temporary directory which is useful for building rpms and other packages. The '/' after ${DESTDIR} will be followed by another '/' at the beginning of the normal install path. When DESTDIR is empty the path then begins with '//', which is incorrect and causes problems at least for Cygwin. The change made in config/commence.am affects many Makefile.*s when bin/reconfigure is run. EXAMPLEDIRs had to be corrected individually. Also the scripts to run examples after they are installed have checks added to see that the fortran and c++ directories are present before trying to run the scripts in them. Tested with h5committest on amani, heiwa and jam.
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 179fb17..640fdcb 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -153,7 +153,7 @@ uninstall-doc:
# be successfully built
installcheck-local:
if test -n "${DESTDIR}"; then \
- (cd ${DESTDIR}/$(bindir) && pwd && ./h5redeploy -force); \
+ (cd ${DESTDIR}$(bindir) && pwd && ./h5redeploy -force); \
fi
@(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;