summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2014-12-19 00:52:34 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2014-12-19 00:52:34 (GMT)
commitd6b44d14dccf80d397e2f69aa2d917e0e464fc35 (patch)
tree860e303dd9f900079201a21169d90b7b4b36057b /Makefile.am
parente810de441ee692395437c0d0c053bfba124985a1 (diff)
downloadhdf5-d6b44d14dccf80d397e2f69aa2d917e0e464fc35.zip
hdf5-d6b44d14dccf80d397e2f69aa2d917e0e464fc35.tar.gz
hdf5-d6b44d14dccf80d397e2f69aa2d917e0e464fc35.tar.bz2
[svn-r25901] HDFFV-9046: reorganize hdf5/perform/ directory
Moved perform/ to tools/perform. Updated all the configure related files for the new location. Tested: h5committested plus tested in jam and kite.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 6 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 640fdcb..0fbf2ea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,8 +73,8 @@ else
endif
SUBDIRS = src test $(TESTPARALLEL_DIR) tools . $(CXX_DIR) $(FORTRAN_DIR) \
- $(HDF5_HL_DIR) perform
-DIST_SUBDIRS = src test testpar tools . c++ fortran hl perform examples
+ $(HDF5_HL_DIR)
+DIST_SUBDIRS = src test testpar tools . c++ fortran hl examples
# Some files generated during configure that should be cleaned
DISTCLEANFILES=config/stamp1 config/stamp2
@@ -93,25 +93,17 @@ lib progs check-p check-s:
fi; \
done
-# Make all, tests, and (un)install also recurse into perform directory
-all-local:
- @cd perform && $(MAKE) $(AM_MAKEFLAGS) all
-
+# Make all, tests, and (un)install
tests:
- @@SETX@; for d in $(SUBDIRS) perform; do \
+ @@SETX@; for d in $(SUBDIRS); do \
if test $$d != .; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
fi; \
done
-install-exec-local:
- @cd perform && $(MAKE) $(AM_MAKEFLAGS) install
-uninstall-local:
- @cd perform && $(MAKE) $(AM_MAKEFLAGS) uninstall
-
# Check-clean also recurses into examples directory
check-clean:
- @@SETX@; for d in $(SUBDIRS) examples perform; do \
+ @@SETX@; for d in $(SUBDIRS) examples; do \
if test $$d != .; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
fi; \
@@ -201,4 +193,4 @@ check-vfd:
$(top_builddir)/config.status:
# Don't include conclude.am in root Makefile; tests target needs to
-# recurse into perform directory as well as reguar subdirs.
+# recurse into reguar subdirs.