summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2009-04-14 22:07:24 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2009-04-14 22:07:24 (GMT)
commit773f3686f0baafe4e783e7e81ff83ec2a883f577 (patch)
tree72b6d1d59763b1b5a6efe8ba51636be8b04cdd41 /Makefile.am
parent2049a2691cab4650714f1e0f648343b1b856982f (diff)
downloadhdf5-773f3686f0baafe4e783e7e81ff83ec2a883f577.zip
hdf5-773f3686f0baafe4e783e7e81ff83ec2a883f577.tar.gz
hdf5-773f3686f0baafe4e783e7e81ff83ec2a883f577.tar.bz2
[svn-r16749] New feature (Bug ID: 1345):
Added a Make target of check-all-install to test the correctness of installing via the prefix= or $DESTDIR options. Platforms tested: h5committested and jam serial mode. Then test check-all-install by hand.
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c0d6827..8e6a4ab 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,6 +79,9 @@ DIST_SUBDIRS = src test testpar tools . c++ fortran hl perform examples
# Some files generated during configure that should be cleaned
DISTCLEANFILES=config/stamp1 config/stamp2
+# Some files/directories generated during check that should be cleaned
+CHECK_CLEANFILES+=*-tmp
+
# Define rules for lib, progs, check, and tests.
# These simply involve recursing into subdirectories.
test _test: check
@@ -113,6 +116,7 @@ check-clean:
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
fi; \
done
+ $(RM) -rf prefix-tmp destdir-tmp
# Some C++ compilers/linkers will create a directory named ii_files in
# the root directory, which should be cleaned.
@@ -150,6 +154,23 @@ installcheck-local:
# check-install is just a synonym for installcheck
check-install: installcheck
+# check-all-install tests installing default vs. prefix=<dir> vs. $DESTDIR.
+# Install via different mechanism and then compare against the default.
+# Fine if only libXXX.a files are different since they may have been ranlib'ed.
+check-all-install:
+ @echo Installing to default location
+ $(MAKE) install
+ @echo Installing to different prefix location
+ $(MAKE) prefix=${ROOT}/prefix-tmp install
+ @echo Compare against the default installation.
+ @echo Fine if only libXXX.a files are different.
+ -diff -r prefix-tmp ${prefix}
+ @echo Installing to different DESTDIR location
+ $(MAKE) DESTDIR=${ROOT}/destdir-tmp install
+ @echo Compare against the default installation.
+ @echo Fine if only libXXX.a files are different.
+ -diff -r destdir-tmp${prefix} ${prefix}
+
# Only source files in the src directory include tracing information,
# so 'make trace' only needs to recurse into that directory.
trace: