summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-03-23 14:22:34 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-03-23 14:22:34 (GMT)
commit524d25498fb7e39b2ad13e674afb8a0ae3844434 (patch)
treef6330aec61ddaa49f41afdb9ddc112165064a75d /Makefile.am
parent15f0a2e95c3c6ea72fe88fe8c9bc45cab7eb3212 (diff)
downloadhdf5-524d25498fb7e39b2ad13e674afb8a0ae3844434.zip
hdf5-524d25498fb7e39b2ad13e674afb8a0ae3844434.tar.gz
hdf5-524d25498fb7e39b2ad13e674afb8a0ae3844434.tar.bz2
[svn-r12143] Purpose:
Bug fix Description: make check-clean didn't clean results of example tests Solution: Fixed Makefiles so that check-clean recurses into example directories. Also a little Makefile cleanup. Platforms tested: mir, modi4, heping, copper
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am23
1 files changed, 16 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index f9d2e8a..654b5c9 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -84,19 +84,20 @@ test _test: check
lib progs check-p check-s:
@@SETX@; for d in $(SUBDIRS); do \
- if test $$d != .; then \
+ if test $$d != .; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
- fi; \
+ fi; \
done
# Make all, tests, and (un)install also recurse into perform directory
all-local:
@cd perform && $(MAKE) $(AM_MAKEFLAGS) all
-tests check-clean:
+
+tests:
@@SETX@; for d in $(SUBDIRS) perform; do \
- if test $$d != .; then \
+ if test $$d != .; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
- fi; \
+ fi; \
done
install-exec-local:
@@ -104,12 +105,20 @@ install-exec-local:
uninstall-local:
@cd perform && $(MAKE) $(AM_MAKEFLAGS) uninstall
+# Check-clean also recurses into examples directory
+check-clean:
+ @@SETX@; for d in $(SUBDIRS) examples perform; do \
+ if test $$d != .; then \
+ (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
+ fi; \
+ done
+
# Some C++ compilers/linkers will create a directory named ii_files in
# the root directory, which should be cleaned.
mostlyclean-local:
if test -d ii_files; then \
- $(RM) -rf ii_files; \
- fi
+ $(RM) -rf ii_files; \
+ fi
# 'make install-all' also installs examples
install-all: