summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-07-21 19:28:11 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-07-21 19:28:11 (GMT)
commit7236935a9d666926b5843f317a84743ef3d4126a (patch)
tree21d7f4f7d0fbc1348c374ba39f9b2ca095841e81 /Makefile.am
parentbb31e94a924a1b3f6f1da6c10ffe95029c87d5c5 (diff)
downloadhdf5-7236935a9d666926b5843f317a84743ef3d4126a.zip
hdf5-7236935a9d666926b5843f317a84743ef3d4126a.tar.gz
hdf5-7236935a9d666926b5843f317a84743ef3d4126a.tar.bz2
[svn-r11095] Purpose:
Configuration feature Description: Serial test output is now stored in log files and printed when all tests in a directory complete, or when a test fails. This should make test output more readable and useful. Also made changes to clean up ii_files directories that are created by some C++ compilers/linkers. Also fixed a few minor Makefile bugs. Solution: When serial tests run, their output is saved in *.log or *.logsh. While running, tests only print when they begin and when they complete; their more specific output (from the log file) is printed if the test fails or when all tests have completed. Comments welcome. Platforms tested: mir, modi4 (parallel and serial), copper, shanti
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index a05876b..7374a1c 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -113,12 +113,17 @@ clean-local:
fi; \
done
+# Some C++ compilers/linkers will create a directory named ii_files in
+# the root directory, which should be cleaned.
mostlyclean-local:
@@SETX@; for d in examples perform; do \
if test -f $$d/Makefile; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) mostlyclean) || exit 1; \
fi; \
- done
+ done; \
+ if test -d ii_files; then \
+ $(RM) -rf ii_files; \
+ fi
# 'make install-all' also installs examples
install-all:
@@ -143,9 +148,6 @@ uninstall-doc:
# `make check-install' or `make installcheck' checks that examples can
# be successfully built
-check-install:
- $(MAKE) $(AM_MAKEFLAGS) installcheck
-
installcheck-local:
(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;