summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-11-03 16:42:09 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-11-03 16:42:09 (GMT)
commitc812f3fea2c9bacfc0f2d2bcad6960e9aa640dcd (patch)
tree79245efc0218e670e8c5edd9eb0d57ad045f0633 /Makefile.am
parentdc47bb7084d55993a0a6f3725dcf79d92d7f0e65 (diff)
downloadhdf5-c812f3fea2c9bacfc0f2d2bcad6960e9aa640dcd.zip
hdf5-c812f3fea2c9bacfc0f2d2bcad6960e9aa640dcd.tar.gz
hdf5-c812f3fea2c9bacfc0f2d2bcad6960e9aa640dcd.tar.bz2
Add doxygen auotoconf and cmake support
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9cb5d02..21bc550 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -187,6 +187,16 @@ check-all-install:
trace:
@(cd src && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+# Run doxygen across source files.
+# Currently, only invoke doxygen in the src directory.
+doxygen:
+ @echo Invoking doxygen
+ for d in src; do \
+ if test $$d != .; then \
+ (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
+ fi; \
+ done
+
# Run tests with different Virtual File Drivers.
# Currently, only invoke check-vfd in the test directory.
check-vfd: