summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2018-11-29 01:07:30 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2018-11-29 01:07:30 (GMT)
commitd442fe2d9815a83f5010cca9a878974e286c27f9 (patch)
treece32b6875ad90d309f81844eaeb20c4a4860025c /Makefile.am
parent6eabeabdaa77642fd4db5fd234ccc756a24125be (diff)
downloadhdf5-d442fe2d9815a83f5010cca9a878974e286c27f9.zip
hdf5-d442fe2d9815a83f5010cca9a878974e286c27f9.tar.gz
hdf5-d442fe2d9815a83f5010cca9a878974e286c27f9.tar.bz2
Add support for "make check-vol", along with a few minor cleanups, etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e3e5e3d..d58b1b4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -186,6 +186,15 @@ check-vfd:
fi; \
done
+# Run tests with different Virtual Object Layer Connectors.
+# Currently, only invoke check-vol in the test directory.
+check-vol:
+ for d in src test; do \
+ if test $$d != .; then \
+ (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
+ fi; \
+ done
+
# Automake wants to make config.status depend on configure. This
# makes sense, but config.status can't always be regenerated
# properly, which can cause builds to fail.