summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2021-05-07 17:56:07 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2021-05-07 17:56:07 (GMT)
commit7f58a89578b64df2b040d97294cb1cf2a82bebd3 (patch)
treede9971f9f1537a23e2ab59fa1ad4c2631164d20e /Makefile.am
parent79b92df2a262c09eb7461c5bbd9500209573653b (diff)
downloadhdf5-7f58a89578b64df2b040d97294cb1cf2a82bebd3.zip
hdf5-7f58a89578b64df2b040d97294cb1cf2a82bebd3.tar.gz
hdf5-7f58a89578b64df2b040d97294cb1cf2a82bebd3.tar.bz2
Misc normalization from develop
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 7 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index cc38972..8518114 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,9 @@
include $(top_srcdir)/config/commence.am
+# include Doxygen rules (requires autoconf-archive >2016-03-20)
+@DX_RULES@
+
# Define subdirectories to build.
## Automake understands that `make distclean' should recurse into
## conditional subdirectories even if `make all' does not.
@@ -187,15 +190,10 @@ check-all-install:
trace:
@(cd src && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
-# Run doxygen across source files.
-# Currently, only invoke doxygen in the src directory.
-doxygen:
- @echo Invoking doxygen
- for d in src; do \
- if test $$d != .; then \
- (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
- fi; \
- done
+# doxygen support
+if BUILD_DOXYGEN_CONDITIONAL
+doxygen: doxygen-doc
+endif
# Run tests with different Virtual File Drivers.
# Currently, only invoke check-vfd in the test directory.