summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2020-11-14 17:58:52 (GMT)
committerGitHub <noreply@github.com>2020-11-14 17:58:52 (GMT)
commitec48fb8dfdb4f2f59f22a5efb6b950aafcac449d (patch)
treec7f15d0a91a22d3340a189ecb680ec21a571bd53 /Makefile.am
parent5b0b132fb0118caba14998df7544fca329939160 (diff)
parent01153cef8b2ce42b4bb7c1f0db6da9cee0a1edf1 (diff)
downloadhdf5-ec48fb8dfdb4f2f59f22a5efb6b950aafcac449d.zip
hdf5-ec48fb8dfdb4f2f59f22a5efb6b950aafcac449d.tar.gz
hdf5-ec48fb8dfdb4f2f59f22a5efb6b950aafcac449d.tar.bz2
Merge pull request #89 from byrnHDF/hdf5_1_12
Hdf5 1 12 doxygen support framework
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9cb5d02..21bc550 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -187,6 +187,16 @@ check-all-install:
trace:
@(cd src && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+# Run doxygen across source files.
+# Currently, only invoke doxygen in the src directory.
+doxygen:
+ @echo Invoking doxygen
+ for d in src; do \
+ if test $$d != .; then \
+ (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
+ fi; \
+ done
+
# Run tests with different Virtual File Drivers.
# Currently, only invoke check-vfd in the test directory.
check-vfd: