summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2014-12-17 23:07:24 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2014-12-17 23:07:24 (GMT)
commitd9ba0ae35fce3c6fdf2559753093338061588c00 (patch)
tree4160f420ade0df1ebfc561b4e61d55dfd34dc5e8 /Makefile.am
parent4c24346fe1c5ff4ff9e4a9ae7ffec2b5ef9cd922 (diff)
downloadhdf5-d9ba0ae35fce3c6fdf2559753093338061588c00.zip
hdf5-d9ba0ae35fce3c6fdf2559753093338061588c00.tar.gz
hdf5-d9ba0ae35fce3c6fdf2559753093338061588c00.tar.bz2
[svn-r25900] HDFFV-9046: reorganize hdf5/perform/ directory
Moved perform/ to tools/perform. Updated all the configure related files for the new location. Tested: h5committested plus tested in jam and kite.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 8 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index 640fdcb..aaa3b9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,13 +73,13 @@ else
endif
SUBDIRS = src test $(TESTPARALLEL_DIR) tools . $(CXX_DIR) $(FORTRAN_DIR) \
- $(HDF5_HL_DIR) perform
-DIST_SUBDIRS = src test testpar tools . c++ fortran hl perform examples
+ $(HDF5_HL_DIR)
+DIST_SUBDIRS = src test testpar tools . c++ fortran hl examples
# Some files generated during configure that should be cleaned
DISTCLEANFILES=config/stamp1 config/stamp2
-# Some files/directories generated during check that should be cleaned
+# Some files/directories generated during checkperform that should be cleaned
CHECK_CLEANFILES+=*-tmp
# Define rules for lib, progs, check, and tests.
@@ -93,25 +93,17 @@ lib progs check-p check-s:
fi; \
done
-# Make all, tests, and (un)install also recurse into perform directory
-all-local:
- @cd perform && $(MAKE) $(AM_MAKEFLAGS) all
-
+# Make all, tests, and (un)install also recurse into directory
tests:
- @@SETX@; for d in $(SUBDIRS) perform; do \
+ @@SETX@; for d in $(SUBDIRS); do \
if test $$d != .; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
fi; \
- done
-
-install-exec-local:
- @cd perform && $(MAKE) $(AM_MAKEFLAGS) install
-uninstall-local:
- @cd perform && $(MAKE) $(AM_MAKEFLAGS) uninstall
+ done
# Check-clean also recurses into examples directory
check-clean:
- @@SETX@; for d in $(SUBDIRS) examples perform; do \
+ @@SETX@; for d in $(SUBDIRS) examples; do \
if test $$d != .; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
fi; \
@@ -201,4 +193,4 @@ check-vfd:
$(top_builddir)/config.status:
# Don't include conclude.am in root Makefile; tests target needs to
-# recurse into perform directory as well as reguar subdirs.
+# recurse into reguar subdirs.