summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2021-08-19 13:59:18 (GMT)
committerGitHub <noreply@github.com>2021-08-19 13:59:18 (GMT)
commit142c8515e7c84af692aee2281558fd58fcc6d587 (patch)
treed285a721ac66762369420ab9abf32bc7c4e0b84d /Makefile.am
parent7e83e0574f43330e4b10b537267f7506b8d0ef20 (diff)
downloadhdf5-142c8515e7c84af692aee2281558fd58fcc6d587.zip
hdf5-142c8515e7c84af692aee2281558fd58fcc6d587.tar.gz
hdf5-142c8515e7c84af692aee2281558fd58fcc6d587.tar.bz2
Brings doxygen changes from develop/1.12 for out-of-source builds (#936)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 7 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d7d923..fede167 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,9 @@
include $(top_srcdir)/config/commence.am
+# include Doxygen rules (requires autoconf-archive >2016-03-20)
+@DX_RULES@
+
# Define subdirectories to build.
## Automake understands that `make distclean' should recurse into
## conditional subdirectories even if `make all' does not.
@@ -187,15 +190,10 @@ check-all-install:
trace:
@(cd src && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
-# Run doxygen across source files.
-# Currently, only invoke doxygen in the src directory.
-doxygen:
- @echo Invoking doxygen
- for d in src; do \
- if test $$d != .; then \
- (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
- fi; \
- done
+# doxygen support
+if BUILD_DOXYGEN_CONDITIONAL
+doxygen: doxygen-doc
+endif
# Run tests with different Virtual File Drivers.
# Currently, only invoke check-vfd in the test directory.