summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDhvanil Popat <dpopat@hdfgroup.org>2019-06-25 01:40:07 (GMT)
committerDhvanil Popat <dpopat@hdfgroup.org>2019-06-25 01:40:07 (GMT)
commit5d954a0214fa92aec884cdbccab10632a925fc08 (patch)
treee0f7ec80bb373be7685f4b38c1e7ccdd5902c1b1 /Makefile.am
parent39537399a10dc27ac22a804e55d77d7160d1bd76 (diff)
downloadhdf5-5d954a0214fa92aec884cdbccab10632a925fc08.zip
hdf5-5d954a0214fa92aec884cdbccab10632a925fc08.tar.gz
hdf5-5d954a0214fa92aec884cdbccab10632a925fc08.tar.bz2
Squash commit of options to build tools and tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 17 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index e3e5e3d..af3d634 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,11 +49,6 @@ include $(top_srcdir)/config/commence.am
# Conditionals. These conditionals are defined during configure
# Define each variable to empty if it is not used to placate pmake
-if BUILD_PARALLEL_CONDITIONAL
- TESTPARALLEL_DIR =testpar
-else
- TESTPARALLEL_DIR=
-endif
if BUILD_CXX_CONDITIONAL
CXX_DIR =c++
else
@@ -74,9 +69,24 @@ if BUILD_HDF5_HL_CONDITIONAL
else
HDF5_HL_DIR=
endif
+if BUILD_TESTS_CONDITIONAL
+ TESTSERIAL_DIR =test
+else
+ TESTSERIAL_DIR=
+endif
+if BUILD_TESTS_PARALLEL_CONDITIONAL
+ TESTPARALLEL_DIR =testpar
+else
+ TESTPARALLEL_DIR=
+endif
+if BUILD_TOOLS_CONDITIONAL
+ TOOLS_DIR =tools
+else
+ TOOLS_DIR=
+endif
-SUBDIRS = src test $(TESTPARALLEL_DIR) tools . $(CXX_DIR) $(FORTRAN_DIR) \
- $(JAVA_DIR) $(HDF5_HL_DIR)
+SUBDIRS = src $(TESTSERIAL_DIR) $(TESTPARALLEL_DIR) bin $(TOOLS_DIR) . \
+ $(CXX_DIR) $(FORTRAN_DIR) $(JAVA_DIR) $(HDF5_HL_DIR)
DIST_SUBDIRS = src test testpar tools . c++ fortran hl examples java
# Some files generated during configure that should be cleaned