summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2020-11-20 04:29:01 (GMT)
committerGitHub <noreply@github.com>2020-11-20 04:29:01 (GMT)
commitc421ecca2c0b662bedee45484fd2bff774413dc2 (patch)
tree20dbc79def9c42755a2992a2efa32927ab1b073a /Makefile.am
parent6ab961488afdd27c9f1ab907d557e7406a0e01f9 (diff)
downloadhdf5-c421ecca2c0b662bedee45484fd2bff774413dc2.zip
hdf5-c421ecca2c0b662bedee45484fd2bff774413dc2.tar.gz
hdf5-c421ecca2c0b662bedee45484fd2bff774413dc2.tar.bz2
Add doxygen framework for CMake and autotools (#90)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d31f7c7..ad695b8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -187,6 +187,16 @@ check-all-install:
trace:
@(cd src && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+# Run doxygen across source files.
+# Currently, only invoke doxygen in the src directory.
+doxygen:
+ @echo Invoking doxygen
+ for d in src; do \
+ if test $$d != .; then \
+ (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
+ fi; \
+ done
+
# Run tests with different Virtual File Drivers.
# Currently, only invoke check-vfd in the test directory.
check-vfd: