summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-11-13 15:30:56 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-11-13 15:30:56 (GMT)
commit3e45af68d8f40e486d2fca1583056798b72dca91 (patch)
treee6937760637d5c45aa380f0da57b1f85fbe83c82 /Makefile.am
parent46bc76ab634ed418c51c4dc50741533027a9cec9 (diff)
downloadhdf5-3e45af68d8f40e486d2fca1583056798b72dca91.zip
hdf5-3e45af68d8f40e486d2fca1583056798b72dca91.tar.gz
hdf5-3e45af68d8f40e486d2fca1583056798b72dca91.tar.bz2
Add doxygen framework for CMake and autotools
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9cb5d02..21bc550 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -187,6 +187,16 @@ check-all-install:
trace:
@(cd src && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+# Run doxygen across source files.
+# Currently, only invoke doxygen in the src directory.
+doxygen:
+ @echo Invoking doxygen
+ for d in src; do \
+ if test $$d != .; then \
+ (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
+ fi; \
+ done
+
# Run tests with different Virtual File Drivers.
# Currently, only invoke check-vfd in the test directory.
check-vfd: