summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-07-19 17:58:24 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-07-19 17:58:24 (GMT)
commite9471222f1b0ac282387d146c7e0a5dbd9908177 (patch)
tree7de5b44e6b7c138c821cf2e8cbccaff7a4acd34d /Makefile.am
parent794ba0a251af47b8e3c60afa2fe92d267e2a6b55 (diff)
downloadhdf5-e9471222f1b0ac282387d146c7e0a5dbd9908177.zip
hdf5-e9471222f1b0ac282387d146c7e0a5dbd9908177.tar.gz
hdf5-e9471222f1b0ac282387d146c7e0a5dbd9908177.tar.bz2
[svn-r11085] Purpose:
Bug fix Description: Update Makefiles now that docs are no longer in main hdf5 tree. Solution: Changed root-level Makefile.am not to recurse into docs tree. Removed docs Makefiles from configure.in. Removed config/commence-doc.am, since it is no longer used. Platforms tested: mir (change to Makefiles only)
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am27
1 files changed, 12 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 63786e0..a05876b 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,8 +39,8 @@ include $(top_srcdir)/config/commence.am
# Define subdirectories to build.
## Automake understands that `make distclean' should recurse into
## conditional subdirectories even if `make all' does not.
-## We need to list examples and doc in the DIST_SUBDIRS variable
-## so that they also will be visited by `make distclean'
+## We need to list the examples directory in the DIST_SUBDIRS variable
+## so that it will be visited by `make distclean'
# Add this directory to SUBDIRS so that examples get built after tools
# but before examples in extra interfaces (c++ and fortran).
# Since we're explicitly listing DIST_SUBDIRS, we also need to list
@@ -73,8 +73,7 @@ endif
SUBDIRS = src test $(TESTPARALLEL_DIR) tools . $(CXX_DIR) $(FORTRAN_DIR) \
$(HDF5_HL_DIR)
-DIST_SUBDIRS = src test testpar tools . c++ fortran hl perform examples \
- doc
+DIST_SUBDIRS = src test testpar tools . c++ fortran hl perform examples
# Some files generated during configure that should be cleaned
DISTCLEANFILES=src/H5config.h src/H5pubconf.h config/stamp1 config/stamp2
@@ -105,29 +104,29 @@ install-exec-local:
uninstall-local:
cd perform && $(MAKE) $(AM_MAKEFLAGS) uninstall
-# Clean and mostlyclean need to recurse into docs, examples, and perform
+# Clean and mostlyclean need to recurse into examples and perform
# directories unless they've already been distcleaned.
clean-local:
- @@SETX@; for d in docs examples perform; do \
+ @@SETX@; for d in examples perform; do \
if test -f $$d/Makefile; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) clean) || exit 1; \
fi; \
done
mostlyclean-local:
- @@SETX@; for d in docs examples perform; do \
+ @@SETX@; for d in examples perform; do \
if test -f $$d/Makefile; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) mostlyclean) || exit 1; \
fi; \
done
-# 'make install-all' also installs docs and examples
+# 'make install-all' also installs examples
install-all:
$(MAKE) $(AM_MAKEFLAGS) install
- $(MAKE) $(AM_MAKEFLAGS) install-doc
+ $(MAKE) $(AM_MAKEFLAGS) install-examples
uninstall-all:
$(MAKE) $(AM_MAKEFLAGS) uninstall
- $(MAKE) $(AM_MAKEFLAGS) uninstall-doc
+ $(MAKE) $(AM_MAKEFLAGS) uninstall-examples
# Install examples in this directory and recursively
install-examples uninstall-examples:
@@ -135,14 +134,12 @@ install-examples uninstall-examples:
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
done
-# Install documentation and examples
+# Placeholder to remind users that docs are now in a separate repository.
install-doc:
- $(MAKE) $(AM_MAKEFLAGS) install-examples
- (cd doc && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+ echo "docs no longer live in this tree. Use install-examples to install examples."
uninstall-doc:
- $(MAKE) $(AM_MAKEFLAGS) uninstall-examples
- (cd doc && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+ echo "docs no longer live in this tree. Use install-examples to install examples."
# `make check-install' or `make installcheck' checks that examples can
# be successfully built