summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDhvanil Popat <dpopat@hdfgroup.org>2019-07-16 19:55:41 (GMT)
committerDhvanil Popat <dpopat@hdfgroup.org>2019-07-16 19:55:41 (GMT)
commit6ea31d54b80e8ceaac21a0399117aa4140b919c7 (patch)
tree0ed583989920edefdb876cd94864a52ec5573d29 /Makefile.am
parent2b6e8e76ad8d0312ba9683deb9d7e28cd1748d29 (diff)
downloadhdf5-6ea31d54b80e8ceaac21a0399117aa4140b919c7.zip
hdf5-6ea31d54b80e8ceaac21a0399117aa4140b919c7.tar.gz
hdf5-6ea31d54b80e8ceaac21a0399117aa4140b919c7.tar.bz2
Added options to build tools and tests for HDF5_ 1_8
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 12 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 32dea3e..59da479 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,11 +49,6 @@ include $(top_srcdir)/config/commence.am
# Conditionals. These conditionals are defined during configure
# Define each variable to empty if it is not used to placate pmake
-if BUILD_PARALLEL_CONDITIONAL
- TESTPARALLEL_DIR =testpar
-else
- TESTPARALLEL_DIR=
-endif
if BUILD_CXX_CONDITIONAL
CXX_DIR =c++
else
@@ -69,9 +64,18 @@ if BUILD_HDF5_HL_CONDITIONAL
else
HDF5_HL_DIR=
endif
-
-SUBDIRS = src test $(TESTPARALLEL_DIR) tools . $(CXX_DIR) $(FORTRAN_DIR) \
- $(HDF5_HL_DIR)
+if BUILD_TESTS_CONDITIONAL
+ TESTSERIAL_DIR =test
+else
+ TESTSERIAL_DIR=
+endif
+if BUILD_TESTS_PARALLEL_CONDITIONAL
+ TESTPARALLEL_DIR =testpar
+else
+ TESTPARALLEL_DIR=
+endif
+SUBDIRS = src $(TESTSERIAL_DIR) $(TESTPARALLEL_DIR) . \
+ $(CXX_DIR) $(FORTRAN_DIR) $(HDF5_HL_DIR)
DIST_SUBDIRS = src test testpar tools . c++ fortran hl examples
# Some files generated during configure that should be cleaned