summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-05-12 14:48:32 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-05-12 14:48:32 (GMT)
commit7e7e7c7aef2a800cda8fc44daa64fd388416a646 (patch)
tree6cd23986e1e5936d863ec40e0c2c2881184e7291 /Makefile.am
parentc48f37b3272655b1adae1bb0b0b00ade75f42071 (diff)
downloadhdf5-7e7e7c7aef2a800cda8fc44daa64fd388416a646.zip
hdf5-7e7e7c7aef2a800cda8fc44daa64fd388416a646.tar.gz
hdf5-7e7e7c7aef2a800cda8fc44daa64fd388416a646.tar.bz2
[svn-r14968] Purpose: Bug Fix (Bug 1144)
Description: Tests in perform directory were never getting run, and h5perf* programs were not being installed. Solution: Added another build option, 'make check-perform', which runs the tests in the perform directory. Also modified the Makefiles in the perform directory to install (with 'make install') h5perf when parallel is enabled, and h5perf and h5perf_serial when parallel is disabled Tested: kagiso, smirom, linew
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index edd8ece..9f2574a 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,6 +101,13 @@ tests:
fi; \
done
+check-perform:
+ @@SETX@; for d in perform; do \
+ if test $$d != .; then \
+ (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
+ fi; \
+ done
+
install-exec-local:
@cd perform && $(MAKE) $(AM_MAKEFLAGS) install
uninstall-local: