summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2010-05-12 20:55:52 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2010-05-12 20:55:52 (GMT)
commitfa416bde84a8c219fa570660bbf3ec8ab16320e7 (patch)
tree5430f5c54b5d4a458859f7e9e10723c09e4e7673 /Makefile.am
parenteeeb3937624f7db68680e1074b1154adc780d516 (diff)
downloadhdf5-fa416bde84a8c219fa570660bbf3ec8ab16320e7.zip
hdf5-fa416bde84a8c219fa570660bbf3ec8ab16320e7.tar.gz
hdf5-fa416bde84a8c219fa570660bbf3ec8ab16320e7.tar.bz2
[svn-r18779] Add ${DESTDIR} to scripts and Makefiles so that make DESTDIR=<install directory> install, installcheck and uninstall is supported for installing examples, since they are now installed as part of make install. This was necessary for rpmbuilds, but should also be supported otherwise.
Tested: amani, jam, linew with committest, rpmbuild on jam and amani.
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e1ce4a..4717810 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -152,6 +152,9 @@ uninstall-doc:
# `make check-install' or `make installcheck' checks that examples can
# be successfully built
installcheck-local:
+ if test -n "${DESTDIR}"; then \
+ (cd ${DESTDIR}/$(bindir) && pwd && ./h5redeploy -force); \
+ fi
@(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
# check-install is just a synonym for installcheck