summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2009-04-15 14:17:18 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2009-04-15 14:17:18 (GMT)
commit745d7ff8356ce970f09081f9b86b71a412d9dbf4 (patch)
tree9604821fa29db77ea7bf866a02df95910e997b3e /Makefile.am
parent773f3686f0baafe4e783e7e81ff83ec2a883f577 (diff)
downloadhdf5-745d7ff8356ce970f09081f9b86b71a412d9dbf4.zip
hdf5-745d7ff8356ce970f09081f9b86b71a412d9dbf4.tar.gz
hdf5-745d7ff8356ce970f09081f9b86b71a412d9dbf4.tar.bz2
[svn-r16754] bug fix (ID 1345):
Use environment variable instead of command parameter to test the install via $DESTDIR test. Tested: Jam and smirom by hand. (no h5committest which does not test this change.)
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e6a4ab..c402ac0 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,7 +154,7 @@ installcheck-local:
# check-install is just a synonym for installcheck
check-install: installcheck
-# check-all-install tests installing default vs. prefix=<dir> vs. $DESTDIR.
+# check-all-install tests all installation methods.
# Install via different mechanism and then compare against the default.
# Fine if only libXXX.a files are different since they may have been ranlib'ed.
check-all-install:
@@ -165,8 +165,8 @@ check-all-install:
@echo Compare against the default installation.
@echo Fine if only libXXX.a files are different.
-diff -r prefix-tmp ${prefix}
- @echo Installing to different DESTDIR location
- $(MAKE) DESTDIR=${ROOT}/destdir-tmp install
+ @echo Installing to different \$DESTDIR location
+ env DESTDIR=${ROOT}/destdir-tmp $(MAKE) install
@echo Compare against the default installation.
@echo Fine if only libXXX.a files are different.
-diff -r destdir-tmp${prefix} ${prefix}