summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-05-20 18:03:35 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-05-20 18:03:35 (GMT)
commitba95b9133c12258fcd795f2b3e3597d9273b2f89 (patch)
tree5f8d5419dc847a7e05a9119a91d284dce3b65b01 /Makefile.am
parent984f44479c880e268b224ea6217ee51d475d7bf7 (diff)
downloadhdf5-ba95b9133c12258fcd795f2b3e3597d9273b2f89.zip
hdf5-ba95b9133c12258fcd795f2b3e3597d9273b2f89.tar.gz
hdf5-ba95b9133c12258fcd795f2b3e3597d9273b2f89.tar.bz2
[svn-r10775] Purpose:
Bug fix (kind of...) Description: When trying to 'make distclean', the Makefiles will attempt to re-run configure if configure has changed. This is a nice idea, but prevents the distclean from happening if configure fails (e.g., if the environment has changed). This happens frequently in the Daily Tests when configure is altered. Solution: It turns out to be easier than I had feared to override the dependency that is causing configure to be re-run. Now configure will never be run automatically, even if it is out-of-date. It would be more complicated to cause it to be re-run in all cases except distclean, so we'll try just the inelegant fix for now. Platforms tested: mir. This change doesn't affect the source, only what is built when. The real test will be how the Daily Tests handle changes to configure (like the one I checked in earlier today).
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a15e389..58864e0 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -152,5 +152,14 @@ check-install:
installcheck-local:
(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+# Automake wants to make config.status depend on configure. This
+# makes sense, but config.status can't always be regenerated
+# properly, which can cause builds to fail.
+# This is a problem for our Daily Tests, which need to be able to
+# 'make distclean' reliably before running configure.
+# The simple solution is to override the dependency Automake supplies
+# for config.status so that it will never be regenerated.
+$(top_builddir)/config.status:
+
# Don't include conclude.am in root Makefile; tests target needs to
# recurse into perform directory as well as reguar subdirs.