summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-08-02 17:59:03 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-08-02 17:59:03 (GMT)
commite75a185ecaab4f55afaae0855a40770a300a2cc0 (patch)
treeaa938d97ec85dea32adfad0005fbaac5ef9edb6f /Makefile.am
parent7def00050fd07e93bee65e2e8ad2fac0001cc05e (diff)
downloadhdf5-e75a185ecaab4f55afaae0855a40770a300a2cc0.zip
hdf5-e75a185ecaab4f55afaae0855a40770a300a2cc0.tar.gz
hdf5-e75a185ecaab4f55afaae0855a40770a300a2cc0.tar.bz2
[svn-r11185] Purpose:
Makefile feature Description: 'make check-clean' now cleans *.h5 files created by tests as well as .log and .chkexe files. Solution: check-clean is now a separate target in its own right, which cleans less than mostlyclean (check-clean < mostlyclean < clean < distclean). Platforms tested: mir, heping, modi4 (serial and parallel)
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 03a6dca..e9b8658 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,7 +82,7 @@ DISTCLEANFILES=src/H5config.h src/H5pubconf.h config/stamp1 config/stamp2
# These simply involve recursing into subdirectories.
test _test: check
-lib progs check-p check-s check-clean:
+lib progs check-p check-s:
@@SETX@; for d in $(SUBDIRS); do \
if test $$d != .; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
@@ -92,7 +92,7 @@ lib progs check-p check-s check-clean:
# Make all, tests, and (un)install also recurse into perform directory
all-local:
@cd perform && $(MAKE) $(AM_MAKEFLAGS) all
-tests:
+tests check-clean:
@@SETX@; for d in $(SUBDIRS) perform; do \
if test $$d != .; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \