summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2010-07-09 02:52:14 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2010-07-09 02:52:14 (GMT)
commit10a8b060ca69eafe2eb73e86e7ed56432a2650d5 (patch)
tree9fb057c2a785fdd7691fb69322368602ff4e2ba5 /Makefile.am
parent5d5ffe2373f1f5db3e49da5095466c94d16dca19 (diff)
downloadhdf5-10a8b060ca69eafe2eb73e86e7ed56432a2650d5.zip
hdf5-10a8b060ca69eafe2eb73e86e7ed56432a2650d5.tar.gz
hdf5-10a8b060ca69eafe2eb73e86e7ed56432a2650d5.tar.bz2
[svn-r19059] Brought changes from hdf5_1_8 to add version information for fortran and c++ compilers in libhdf5.settings file and configure output (r18836), to install examples as part of make install (r18680), and to provide scripts to compile and run the examples after they are installed (r18817).
Tested with new/h5committest on amani, heiwa, and jam.
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7acc2db..179fb17 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -125,17 +125,20 @@ mostlyclean-local:
$(RM) -rf ii_files; \
fi
+# 'make install' will now install examples, the same as 'make install-all'.
+# 'make-install-all' will be redundant but will still work.
+install: install-recursive install-examples
+uninstall: uninstall-recursive uninstall-examples
+
# 'make install-all' also installs examples
install-all:
@$(MAKE) $(AM_MAKEFLAGS) install
- @$(MAKE) $(AM_MAKEFLAGS) install-examples
uninstall-all:
@$(MAKE) $(AM_MAKEFLAGS) uninstall
- @$(MAKE) $(AM_MAKEFLAGS) uninstall-examples
# Install examples in this directory and recursively
install-examples uninstall-examples:
- @@SETX@; for d in examples $(HDF5_INTERFACES); do \
+ @@SETX@; for d in examples $(HDF5_INTERFACES) $(HL); do \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
done
@@ -149,6 +152,9 @@ uninstall-doc:
# `make check-install' or `make installcheck' checks that examples can
# be successfully built
installcheck-local:
+ if test -n "${DESTDIR}"; then \
+ (cd ${DESTDIR}/$(bindir) && pwd && ./h5redeploy -force); \
+ fi
@(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
# check-install is just a synonym for installcheck