summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-05-12 15:15:27 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-05-12 15:15:27 (GMT)
commit63e372c5699f197d62731cbd279204b2cc1c45ae (patch)
treef3f3d2886693fde39e58d499aa18be0ec50c1891 /Makefile.am
parent6cdadf3db5d57111f80eb45a587af7eb30336dcb (diff)
downloadhdf5-63e372c5699f197d62731cbd279204b2cc1c45ae.zip
hdf5-63e372c5699f197d62731cbd279204b2cc1c45ae.tar.gz
hdf5-63e372c5699f197d62731cbd279204b2cc1c45ae.tar.bz2
[svn-r14969] Purpose: Bug Fix (Bug 1144)
Description: Tests in perform directory were never getting run, and h5perf* programs were not being installed. Solution: Added another build option, 'make check-perform', which runs the tests in the perform directory. Also modified the Makefiles in the perform directory to install (with 'make install') h5perf when parallel is enabled, and h5perf and h5perf_serial when parallel is disabled. Tested: kagiso, smirom, linew
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index edd8ece..9f2574a 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,6 +101,13 @@ tests:
fi; \
done
+check-perform:
+ @@SETX@; for d in perform; do \
+ if test $$d != .; then \
+ (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
+ fi; \
+ done
+
install-exec-local:
@cd perform && $(MAKE) $(AM_MAKEFLAGS) install
uninstall-local: