summaryrefslogtreecommitdiffstats
path: root/c++/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-08-19 20:35:08 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-08-19 20:35:08 (GMT)
commit7470e8114d2fa875e84dba619b4c79c093c6f707 (patch)
tree3e6307091559520cc03a02781df53c24ca252ae0 /c++/CMakeLists.txt
parent884dcbc7aa0005dc411bccada2339d38363cb8a6 (diff)
downloadhdf5-7470e8114d2fa875e84dba619b4c79c093c6f707.zip
hdf5-7470e8114d2fa875e84dba619b4c79c093c6f707.tar.gz
hdf5-7470e8114d2fa875e84dba619b4c79c093c6f707.tar.bz2
[svn-r27532] Merge of CMake dual-binary changes from CMake branch to 1.8
Tested: local linux (CMake branch has been tested on Windows)
Diffstat (limited to 'c++/CMakeLists.txt')
-rw-r--r--c++/CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/c++/CMakeLists.txt b/c++/CMakeLists.txt
index 39280e8..6f288a0 100644
--- a/c++/CMakeLists.txt
+++ b/c++/CMakeLists.txt
@@ -7,15 +7,6 @@ PROJECT (HDF5_CPP)
add_definitions (${HDF_EXTRA_C_FLAGS})
#-----------------------------------------------------------------------------
-# Shared/Static Libs
-#-----------------------------------------------------------------------------
-if (BUILD_SHARED_LIBS)
- set (CPP_BUILT_AS_DYNAMIC_LIB 1)
-else (BUILD_SHARED_LIBS)
- set (CPP_BUILT_AS_STATIC_LIB 1)
-endif (BUILD_SHARED_LIBS)
-
-#-----------------------------------------------------------------------------
# Generate configure file
#-----------------------------------------------------------------------------
configure_file (${HDF_RESOURCES_DIR}/H5cxx_config.h.in