summaryrefslogtreecommitdiffstats
path: root/c++/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-04-20 15:11:55 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-04-20 15:11:55 (GMT)
commit6c82c49dd5e5ee187ab1da9f54311a1ecab45bb8 (patch)
treeea96affc668bcf047a1e97fbb9cc889892a2d9a9 /c++/CMakeLists.txt
parentb68321b2b3647b23b0820d958ec529c13be121ed (diff)
downloadhdf5-6c82c49dd5e5ee187ab1da9f54311a1ecab45bb8.zip
hdf5-6c82c49dd5e5ee187ab1da9f54311a1ecab45bb8.tar.gz
hdf5-6c82c49dd5e5ee187ab1da9f54311a1ecab45bb8.tar.bz2
TRILABS-20 set a compiler name on all project commands
Diffstat (limited to 'c++/CMakeLists.txt')
-rw-r--r--c++/CMakeLists.txt22
1 files changed, 1 insertions, 21 deletions
diff --git a/c++/CMakeLists.txt b/c++/CMakeLists.txt
index 635c6fe..80bd810 100644
--- a/c++/CMakeLists.txt
+++ b/c++/CMakeLists.txt
@@ -1,25 +1,5 @@
cmake_minimum_required (VERSION 3.10)
-PROJECT (HDF5_CPP)
-
-#-----------------------------------------------------------------------------
-# Apply Definitions to compiler in this directory and below
-#-----------------------------------------------------------------------------
-add_definitions (${HDF_EXTRA_C_FLAGS})
-
-#-----------------------------------------------------------------------------
-# Generate configure file
-#-----------------------------------------------------------------------------
-configure_file (${HDF_RESOURCES_DIR}/H5cxx_config.h.in
- ${HDF5_BINARY_DIR}/H5cxx_pubconf.h
-)
-
-#-----------------------------------------------------------------------------
-# Parallel/MPI, prevent spurious cpp/cxx warnings
-#-----------------------------------------------------------------------------
-if (H5_HAVE_PARALLEL)
- add_definitions ("-DMPICH_SKIP_MPICXX")
- add_definitions ("-DMPICH_IGNORE_CXX_SEEK")
-endif ()
+project (HDF5_CPP CXX)
add_subdirectory (src)