summaryrefslogtreecommitdiffstats
path: root/c++/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-01-04 18:40:26 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-01-04 18:40:26 (GMT)
commit9449cfa3615eadb40d554a1148ca020ac1b0f632 (patch)
treeed9f5207644fcc9ae8b3a828bf104706e1580436 /c++/CMakeLists.txt
parent1c7688c77afe630fc6382f994671ff3d5220279a (diff)
downloadhdf5-9449cfa3615eadb40d554a1148ca020ac1b0f632.zip
hdf5-9449cfa3615eadb40d554a1148ca020ac1b0f632.tar.gz
hdf5-9449cfa3615eadb40d554a1148ca020ac1b0f632.tar.bz2
[svn-r19907] Windows: Correct how fortran links in CRT library. Also correct macro use for checking libtype.
bring r19906 from 1.8 branch
Diffstat (limited to 'c++/CMakeLists.txt')
-rw-r--r--c++/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/c++/CMakeLists.txt b/c++/CMakeLists.txt
index 7571e54..26c9521 100644
--- a/c++/CMakeLists.txt
+++ b/c++/CMakeLists.txt
@@ -6,6 +6,8 @@ PROJECT (HDF5_CPP)
#-----------------------------------------------------------------------------
IF (BUILD_SHARED_LIBS)
SET (CPP_BUILT_AS_DYNAMIC_LIB 1)
+ELSE (BUILD_SHARED_LIBS)
+ SET (CPP_BUILT_AS_STATIC_LIB 1)
ENDIF (BUILD_SHARED_LIBS)
#-----------------------------------------------------------------------------