summaryrefslogtreecommitdiffstats
path: root/c++/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-12-30 14:03:15 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-12-30 14:03:15 (GMT)
commit8a7bf1ae4efd144ddf77f2a1c9701c36f913b5a4 (patch)
treeaf334956696330b4ce9811ca890d41bfd44770e2 /c++/CMakeLists.txt
parenta863723db866ed63377aecd1e90cffa08f43c020 (diff)
downloadhdf5-8a7bf1ae4efd144ddf77f2a1c9701c36f913b5a4.zip
hdf5-8a7bf1ae4efd144ddf77f2a1c9701c36f913b5a4.tar.gz
hdf5-8a7bf1ae4efd144ddf77f2a1c9701c36f913b5a4.tar.bz2
[svn-r19898] Remove use of /MT compile flag for building static libs and programs. Added BUILT_AS_STATIC_LIBRARY define to set the windows import/export defines correctly for static libraries.
Diffstat (limited to 'c++/CMakeLists.txt')
-rw-r--r--c++/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/c++/CMakeLists.txt b/c++/CMakeLists.txt
index 7571e54..26c9521 100644
--- a/c++/CMakeLists.txt
+++ b/c++/CMakeLists.txt
@@ -6,6 +6,8 @@ PROJECT (HDF5_CPP)
#-----------------------------------------------------------------------------
IF (BUILD_SHARED_LIBS)
SET (CPP_BUILT_AS_DYNAMIC_LIB 1)
+ELSE (BUILD_SHARED_LIBS)
+ SET (CPP_BUILT_AS_STATIC_LIB 1)
ENDIF (BUILD_SHARED_LIBS)
#-----------------------------------------------------------------------------