summaryrefslogtreecommitdiffstats
path: root/c++/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-01 03:17:02 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-01 03:17:02 (GMT)
commit26303241febadd20aea77fc8a1d48f05823170af (patch)
tree4ba1d92050fa6cc33feab6a38bc9778f71bbb146 /c++/Makefile.am
parent9f17319144fca94a852fd500487b0e4ae48e0997 (diff)
downloadhdf5-26303241febadd20aea77fc8a1d48f05823170af.zip
hdf5-26303241febadd20aea77fc8a1d48f05823170af.tar.gz
hdf5-26303241febadd20aea77fc8a1d48f05823170af.tar.bz2
[svn-r9902] Purpose:
Configuration feature Description: HDF5 now uses automake to generate Makefiles Solution: Makefile.in files are now generated from Makefile.am files. To reconfigure (after chaning a Makefile.am or configure.in): /bin/sh bin/reconfigure.sh Platforms tested: Many
Diffstat (limited to 'c++/Makefile.am')
-rw-r--r--c++/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/c++/Makefile.am b/c++/Makefile.am
new file mode 100644
index 0000000..c4d6209
--- /dev/null
+++ b/c++/Makefile.am
@@ -0,0 +1,46 @@
+#
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdf.ncsa.uiuc.edu/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from hdfhelp@ncsa.uiuc.edu.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# Top-level HDF5-C++ Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+SUBDIRS=src test
+DIST_SUBDIRS = $(SUBDIRS) examples
+
+# Clean and mostlyclean need to recurse into examples directory
+clean-local:
+ if test -f examples/Makefile; then \
+ (cd examples && $(MAKE) clean) || exit 1; \
+ fi;
+mostlyclean-local:
+ if test -f examples/Makefile; then \
+ (cd examples && $(MAKE) mostlyclean) || exit 1; \
+ fi;
+
+# Install examples
+install-examples uninstall-examples:
+ (cd examples && $(MAKE) $@) || exit 1;
+
+# Check that examples can be successfully built
+check-install:
+ $(MAKE) installcheck
+
+installcheck-local:
+ (cd examples && $(MAKE) $@) || exit 1;
+
+include $(top_srcdir)/config/conclude.am