summaryrefslogtreecommitdiffstats
path: root/c++/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-04-11 21:47:05 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-04-11 21:47:05 (GMT)
commitafef3c035864297dd2ffe537508164ecb87e89e4 (patch)
treecaefd3218d14685f69e90ebe2ab5b3fd4e32b0fd /c++/Makefile.am
parent408471420f13327597fb9c87149bc1bc709f8740 (diff)
downloadhdf5-afef3c035864297dd2ffe537508164ecb87e89e4.zip
hdf5-afef3c035864297dd2ffe537508164ecb87e89e4.tar.gz
hdf5-afef3c035864297dd2ffe537508164ecb87e89e4.tar.bz2
[svn-r10587] Purpose:
Minor feature Description: If a user configures without C++ or Fortran, 'make' will not recurse into c++ or fortran directories. However, if the user cd's into these directories and 'makes,' the Makefiles will attempt to build interfaces that have not been configured, usually failing. In an unrelated but minor change, src/H5detect should be compiled with the -g flag to disable compiler optimizations since it is only executed once. Solution: Make it harder for users to try to compile interfaces that have not been configured by making c++, fortran, and hl directories not recurse into their subdirectories unless they have been configured. Thus, 'make' in /fortran/src will break if Fortran has not been configured, but 'make' in /fortran will not break. Platforms tested: mir, modi4, copper Misc. update:
Diffstat (limited to 'c++/Makefile.am')
-rw-r--r--c++/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/c++/Makefile.am b/c++/Makefile.am
index c4e1c44..98241cc 100644
--- a/c++/Makefile.am
+++ b/c++/Makefile.am
@@ -19,7 +19,10 @@
include $(top_srcdir)/config/commence.am
-SUBDIRS=src test
+## Only recurse into subdirectories if C++ interface is enabled.
+if BUILD_CXX_CONDITIONAL
+ SUBDIRS=src test
+endif
DIST_SUBDIRS = $(SUBDIRS) examples
# Clean and mostlyclean need to recurse into examples directory