summaryrefslogtreecommitdiffstats
path: root/c++/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-08-01 22:22:55 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-08-01 22:22:55 (GMT)
commitc63ef2cba28df827eb090a019284c7cd8c2982af (patch)
tree134ff7254d8ee7b1c6f7fa3eabc509528899d68d /c++/Makefile.am
parentf2240792704b74fc288b4e4a570509c4afe4a34e (diff)
downloadhdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.zip
hdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.tar.gz
hdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.tar.bz2
[svn-r11179] Purpose:
Feature: check-clean target Description: 'make check-clean' cleans up output files from tests. Solution: Tests create foo.chkexe and foo.log files. Scripts create foo.chksh and foo.logsh files. 'make check-clean' will clean these files up so that the tests can be re-run. Also suppressed some not-very-useful output of Makefiles when it would echo commands. Platforms tested: mir, sleipnir, modi4 Misc. update:
Diffstat (limited to 'c++/Makefile.am')
-rw-r--r--c++/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/c++/Makefile.am b/c++/Makefile.am
index a64a215..042fb92 100644
--- a/c++/Makefile.am
+++ b/c++/Makefile.am
@@ -27,23 +27,23 @@ DIST_SUBDIRS = src test examples
# Clean and mostlyclean need to recurse into examples directory
clean-local:
- if test -f examples/Makefile; then \
+ @if test -f examples/Makefile; then \
(cd examples && $(MAKE) $(AM_MAKEFLAGS) clean) || exit 1; \
fi;
mostlyclean-local:
- if test -f examples/Makefile; then \
+ @if test -f examples/Makefile; then \
(cd examples && $(MAKE) $(AM_MAKEFLAGS) mostlyclean) || exit 1; \
fi;
# Install examples
install-examples uninstall-examples:
- (cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+ @(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
# Check that examples can be successfully built
check-install:
- $(MAKE) $(AM_MAKEFLAGS) installcheck
+ @$(MAKE) $(AM_MAKEFLAGS) installcheck
installcheck-local:
- (cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+ @(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
include $(top_srcdir)/config/conclude.am