summaryrefslogtreecommitdiffstats
path: root/c++/Makefile.am
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2019-03-10 03:41:38 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2019-03-10 03:41:38 (GMT)
commitdeeb302747fe186d18bbf3e47d750ce6e47aef62 (patch)
treeeb74d361608c829e7a531165378a5af873ff7ad2 /c++/Makefile.am
parent679b49d43d744f0cc34054944e827326f17a6f3d (diff)
downloadhdf5-deeb302747fe186d18bbf3e47d750ce6e47aef62.zip
hdf5-deeb302747fe186d18bbf3e47d750ce6e47aef62.tar.gz
hdf5-deeb302747fe186d18bbf3e47d750ce6e47aef62.tar.bz2
Specify the default VOL connector to use with an environment variable.
This implicitly adds support for changing the VOL connector for command-line tools or any application linked with the library. Also, add 'make check-vol' support for all directories, clearing up necessary issues in testing scripts, etc.
Diffstat (limited to 'c++/Makefile.am')
-rw-r--r--c++/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/c++/Makefile.am b/c++/Makefile.am
index 94fbefc..3713901 100644
--- a/c++/Makefile.am
+++ b/c++/Makefile.am
@@ -21,6 +21,12 @@ include $(top_srcdir)/config/commence.am
## Only recurse into subdirectories if C++ interface is enabled.
if BUILD_CXX_CONDITIONAL
SUBDIRS=src test
+
+# Test with just the native connector, with a single pass-through connector
+# and with a doubly-stacked pass-through.
+VOL_LIST = native "pass_through under_vol=0;under_info={}" \
+ "pass_through under_vol=505;under_info={under_vol=0;under_info={}}"
+
endif
DIST_SUBDIRS = src test examples