summaryrefslogtreecommitdiffstats
path: root/c++/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2003-03-09 07:11:55 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2003-03-09 07:11:55 (GMT)
commita326fafb16a55b5653090390102e80f32e755983 (patch)
treefdfce9273b612537862b052ee8c624d803f5a39f /c++/configure.in
parent140ad8b1067397a02934a3f6bda1bd4acc2b6440 (diff)
downloadhdf5-a326fafb16a55b5653090390102e80f32e755983.zip
hdf5-a326fafb16a55b5653090390102e80f32e755983.tar.gz
hdf5-a326fafb16a55b5653090390102e80f32e755983.tar.bz2
[svn-r6471] Purpose:
Update Description: Removed useless #includes and added a test for the std environment. Platforms tested: Linux
Diffstat (limited to 'c++/configure.in')
-rw-r--r--c++/configure.in101
1 files changed, 62 insertions, 39 deletions
diff --git a/c++/configure.in b/c++/configure.in
index 3fd7956..1c57cc6 100644
--- a/c++/configure.in
+++ b/c++/configure.in
@@ -1,9 +1,18 @@
dnl ----------------------------------------------------------------------
dnl Process this file with autoconf to produce configure.
dnl
-dnl Copyright (C) 2000, 2001, 2002
-dnl National Center for Supercomputing Applications.
-dnl All rights reserved.
+dnl Copyright by the Board of Trustees of the University of Illinois.
+dnl All rights reserved.
+dnl
+dnl This file is part of HDF5. The full HDF5 copyright notice, including
+dnl terms governing use, modification, and redistribution, is contained in
+dnl the files COPYING and Copyright.html. COPYING can be found at the root
+dnl of the source code distribution tree; Copyright.html can be found at the
+dnl root level of an installed copy of the electronic HDF5 document set and
+dnl is linked from the top-level documents page. It can also be found at
+dnl http://hdf.ncsa.uiuc.edu/HDF5/doc/Copyright.html. If you do not have
+dnl access to either file, you may request a copy from hdfhelp@ncsa.uiuc.edu.
+dnl
dnl ----------------------------------------------------------------------
dnl ----------------------------------------------------------------------
@@ -20,7 +29,6 @@ dnl release!!!
dnl
AC_INIT([HDF5 C++], [1.5.49], [hdfhelp@ncsa.uiuc.edu])
AC_CONFIG_SRCDIR([src/H5Library.cpp])
-
AC_CONFIG_AUX_DIR([../bin])
AC_CANONICAL_HOST
@@ -120,17 +128,17 @@ for f in $host_cpu-$host_vendor-$host_os \
$host_os_novers \
$host_vendor \
$host_cpu ; do
- AC_MSG_CHECKING(for config $f)
- if test -f $srcdir/config/$f; then
- host_config=$srcdir/config/$f
- AC_MSG_RESULT(found)
- break
- fi
- AC_MSG_RESULT(no)
+ AC_MSG_CHECKING(for config $f)
+ if test -f $srcdir/config/$f; then
+ host_config=$srcdir/config/$f
+ AC_MSG_RESULT(found)
+ break
+ fi
+ AC_MSG_RESULT(no)
done
if test "X$host_config" != "Xnone"; then
- CXX_BASENAME="`echo $CXX |cut -f1 -d' ' |xargs basename 2>/dev/null`"
- . $host_config
+ CXX_BASENAME="`echo $CXX |cut -f1 -d' ' |xargs basename 2>/dev/null`"
+ . $host_config
fi
dnl ----------------------------------------------------------------------
@@ -152,8 +160,12 @@ if test "X$GCC" = "Xyes"; then
AC_CHECK_PROGS(PERL, perl,, $PATH)
fi
+dnl ----------------------------------------------------------------------
+dnl Check which archiving tool to use. This needs to be done before
+dnl the AM_PROG_LIBTOOL macro.
+dnl
if test -z "$AR"; then
- AC_CHECK_PROGS(AR,ar xar,:,$PATH)
+ AC_CHECK_PROGS(AR,ar xar,:,$PATH)
fi
AC_SUBST(AR)
@@ -170,7 +182,7 @@ if test -z "$SEARCH"; then
VPATH=$srcdir/config $srcdir/src $srcdir/bin
.c.o:
cp $< H5.o
-
+
foo: H5.o
/bin/rm -f H5.o
@echo works
@@ -189,12 +201,12 @@ EOF
VPATH=$srcdir/config:$srcdir/src:$srcdir/bin
.c.o:
cp $< H5.o
-
+
foo: H5.o
/bin/rm -f H5.o
@echo works
EOF
-
+
if (${MAKE-make} -f maketest foo) >/dev/null 2>&1; then
SEARCH_RULE='VPATH='
SEARCH_SEP=':'
@@ -235,15 +247,16 @@ dnl ----------------------------------------------------------------------
dnl Production flags? Save the value in $CONFIG_MODE so we have it for
dnl the record.
dnl
-AC_MSG_CHECKING(for production mode)
-AC_ARG_ENABLE(production,
- [ --enable-production Determines how to run the compiler.])
+AC_MSG_CHECKING([for production mode])
+AC_ARG_ENABLE([production],
+ [AC_HELP_STRING([--enable-production],
+ [Determines how to run the compiler.])])
case "X-$enable_production" in
X-yes)
AC_MSG_RESULT("production")
- dnl Remove the "-g" flag from CXXFLAGS if it's in there.
+ dnl Remove the "-g" flag from CFLAGS if it's in there.
dnl
CXXFLAGS_temp=""
if test -n "$CXXFLAGS"; then
@@ -307,7 +320,7 @@ case "$host_cpu-$host_vendor-$host_os" in
[AC_HELP_STRING([--enable-linux-lfs],
[Enable support for large (64-bit)
files on Linux. [default=check]])])
-
+
LINUX_LFS="no"
case "X-$enable_linux_lfs" in
X-yes)
@@ -324,13 +337,14 @@ case "$host_cpu-$host_vendor-$host_os" in
fi
;;
esac
-
+
AC_MSG_CHECKING([for large file support mode on Linux])
if test "X$LINUX_LFS" = "Xyes"; then
- AC_MSG_RESULT([enabled])
+ AC_MSG_RESULT(enabled)
+
CPPFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE $CPPFLAGS"
else
- AC_MSG_RESULT([disabled])
+ AC_MSG_RESULT(disabled)
fi
dnl Add POSIX support on Linux systems, so <features.h> defines
@@ -365,14 +379,6 @@ int main(void) { return 0; }
AC_MSG_CHECKING(if $CXX can handle namespaces)
AC_TRY_RUN([
-#ifdef OLD_HEADER_FILENAME
-#include <iostream.h>
-#else
-#include <iostream>
-#endif
-
-using namespace std;
-
namespace H5 {
int fnord;
}
@@ -383,10 +389,27 @@ int main(void) {
return 0;
}
], [
- echo yes
+ echo yes
], [
- echo no
- CXXFLAGS="${CXXFLAGS} -DH5_NO_NAMESPACE"
+ echo no
+ CXXFLAGS="${CXXFLAGS} -DH5_NO_NAMESPACE"
+])
+
+AC_MSG_CHECKING(if $CXX supports std)
+AC_TRY_RUN([
+#include <string>
+
+using namespace std;
+
+int main(void) {
+ string myString("testing namespace std");
+ return 0;
+}
+], [
+ echo yes
+], [
+ echo no
+ CXXFLAGS="${CXXFLAGS} -DH5_NO_STD"
])
AC_MSG_CHECKING(if $CXX supports bool types)
@@ -396,10 +419,10 @@ int main(void) {
return 0;
}
], [
- echo yes
+ echo yes
], [
- echo no
- CXXFLAGS="${CXXFLAGS} -DBOOL_NOTDEFINED"
+ echo no
+ CXXFLAGS="${CXXFLAGS} -DBOOL_NOTDEFINED"
])
AC_MSG_CHECKING(if $CXX can handle static cast)