summaryrefslogtreecommitdiffstats
path: root/c++/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2001-04-13 17:20:03 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2001-04-13 17:20:03 (GMT)
commitcbab37d78c167781a0928f754267db1578c2ab0a (patch)
tree64c2dc6efc94a6c41f3f19884652745252bd5cd7 /c++/configure.in
parent7e05b02ab39c297e21cb3926f399a8ced870a9b4 (diff)
downloadhdf5-cbab37d78c167781a0928f754267db1578c2ab0a.zip
hdf5-cbab37d78c167781a0928f754267db1578c2ab0a.tar.gz
hdf5-cbab37d78c167781a0928f754267db1578c2ab0a.tar.bz2
[svn-r3810] Purpose:
Update Description: Removed test for zlib since the C++ library doesn't need it.
Diffstat (limited to 'c++/configure.in')
-rw-r--r--c++/configure.in39
1 files changed, 0 insertions, 39 deletions
diff --git a/c++/configure.in b/c++/configure.in
index bf2a2e4..3e34a38 100644
--- a/c++/configure.in
+++ b/c++/configure.in
@@ -321,45 +321,6 @@ int main(void) {
])
dnl ----------------------------------------------------------------------
-dnl Is the GNU zlib present? It has a header file `zlib.h' and a library
-dnl `-lz' and their locations might be specified with the `--with-zlib'
-dnl command-line switch. The value is an include path and/or a library path.
-dnl If the library path is specified then it must be preceded by a comma.
-dnl
-
-AC_ARG_WITH(zlib,[ --with-zlib=INC,LIB Use the GNU zlib compression],
- ,withval=yes)
-case $withval in
- yes)
- AC_CHECK_HEADERS(zlib.h)
- AC_CHECK_LIB(z, compress)
- ;;
- no)
- AC_MSG_CHECKING(for GNU zlib)
- AC_MSG_RESULT(suppressed)
- ;;
- *)
- zlib_inc="`echo $withval |cut -f1 -d,`"
- if test -n "$zlib_inc"; then
- saved_CPPFLAGS="$CPPFLAGS"
- CPPFLAGS="$CPPFLAGS -I$zlib_inc"
- AC_CHECK_HEADERS(zlib.h,,CPPFLAGS="$saved_CPPFLAGS")
- else
- AC_CHECK_HEADERS(zlib.h)
- fi
-
- zlib_lib="`echo $withval |cut -f2 -d, -s`"
- if test -n "$zlib_lib"; then
- saved_LDFLAGS="$LDFLAGS"
- LDFLAGS="$LDFLAGS -L$zlib_lib"
- AC_CHECK_LIB(z, compress,,LDFLAGS="$saved_LDFLAGS")
- else
- AC_CHECK_LIB(z, compress)
- fi
- ;;
-esac
-
-dnl ----------------------------------------------------------------------
dnl Checks for header files.
dnl