summaryrefslogtreecommitdiffstats
path: root/c++/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2000-11-15 16:04:48 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2000-11-15 16:04:48 (GMT)
commit8dcb33c00ecaaa6f885a31aad0122632e4340e83 (patch)
tree7654e4d6c2925b034dcb669055bd025e30e9b6ec /c++/configure.in
parente46bc7f20607dece99e9827c51b75205d856f7f6 (diff)
downloadhdf5-8dcb33c00ecaaa6f885a31aad0122632e4340e83.zip
hdf5-8dcb33c00ecaaa6f885a31aad0122632e4340e83.tar.gz
hdf5-8dcb33c00ecaaa6f885a31aad0122632e4340e83.tar.bz2
[svn-r2913] Purpose:
Bug fix Description: Configure wasn't picking up the LT_STATIC_EXEC stuff from the top-level configure. Solution: Added LT_STATIC_EXEC logic Platforms tested: Linux
Diffstat (limited to 'c++/configure.in')
-rw-r--r--c++/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/c++/configure.in b/c++/configure.in
index 73126c6..e56219f 100644
--- a/c++/configure.in
+++ b/c++/configure.in
@@ -203,6 +203,23 @@ EOF
fi
dnl ----------------------------------------------------------------------
+dnl If we should build only static executables
+dnl
+AC_MSG_CHECKING(if should build only statically linked executables)
+AC_ARG_ENABLE(static_exec,
+ [ --enable-static-exec Build only statically linked executables [default=no]],
+ STATIC_EXEC=$enableval)
+
+if test "X$STATIC_EXEC" = "Xyes"; then
+ echo "yes"
+ LT_STATIC_EXEC="-all-static"
+else
+ echo "no"
+ LT_STATIC_EXEC=""
+fi
+AC_SUBST(LT_STATIC_EXEC)
+
+dnl ----------------------------------------------------------------------
dnl Checks for compiler characteristics.
dnl
AC_LANG_CPLUSPLUS