summaryrefslogtreecommitdiffstats
path: root/c++/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2000-11-15 20:01:16 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2000-11-15 20:01:16 (GMT)
commit3fe3fde6f47037ace71cee5d6740a1da8e95a9da (patch)
treea66bdd5a88dfdabca97c720bc88e19655ebf5025 /c++/configure.in
parent488adf66709afb339f35f6fb46779984487d0b49 (diff)
downloadhdf5-3fe3fde6f47037ace71cee5d6740a1da8e95a9da.zip
hdf5-3fe3fde6f47037ace71cee5d6740a1da8e95a9da.tar.gz
hdf5-3fe3fde6f47037ace71cee5d6740a1da8e95a9da.tar.bz2
[svn-r2937] Purpose:
Feature Update Description: Added ability to compile code as production, development, or profile with the appropriate flags...
Diffstat (limited to 'c++/configure.in')
-rw-r--r--c++/configure.in33
1 files changed, 33 insertions, 0 deletions
diff --git a/c++/configure.in b/c++/configure.in
index 0b61bc4..c489950 100644
--- a/c++/configure.in
+++ b/c++/configure.in
@@ -203,6 +203,39 @@ EOF
fi
dnl ----------------------------------------------------------------------
+dnl Production flags? Save the value in $CONFIG_MODE so we have it for
+dnl the record.
+dnl
+AC_MSG_CHECKING(for production mode)
+AC_ARG_ENABLE(production,
+ [ --enable-production Determines how to run the compiler.])
+
+case "X-$enable_production" in
+ X-yes)
+ AC_MSG_RESULT("production")
+ CONFIG_MODE=production
+ CXXFLAGS="$CXXFLAGS $PROD_CXXFLAGS"
+ CPPFLAGS="$CPPFLAGS $PROD_CPPFLAGS"
+ ;;
+ X-|X-no)
+ AC_MSG_RESULT("development")
+ CONFIG_MODE=development
+ CXXFLAGS="$CFLAGS $DEBUG_CXXFLAGS"
+ CPPFLAGS="$CPPFLAGS $DEBUG_CPPFLAGS"
+ ;;
+ X-pg|X-profile)
+ AC_MSG_RESULT("profile")
+ CONFIG_MODE=profile
+ CXXFLAGS="$CFLAGS $PROFILE_CXXFLAGS"
+ CPPFLAGS="$CPPFLAGS $PROFILE_CPPFLAGS"
+ ;;
+ *)
+ AC_MSG_RESULT("user-defined")
+ CONFIG_MODE="$X-enableval"
+ ;;
+esac
+
+dnl ----------------------------------------------------------------------
dnl If we should build only static executables
dnl
AC_MSG_CHECKING(if should build only statically linked executables)