summaryrefslogtreecommitdiffstats
path: root/c++/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-08-26 15:35:15 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-08-26 15:35:15 (GMT)
commit8194f34ef79a58dc5e57b374873be4e50ad7ad7b (patch)
tree876b1d75477a2babe7fd8a7ef555611825e52526 /c++/examples/CMakeLists.txt
parenta17e786cd732ca3af91ebb473a0bd116f391c94a (diff)
downloadhdf5-8194f34ef79a58dc5e57b374873be4e50ad7ad7b.zip
hdf5-8194f34ef79a58dc5e57b374873be4e50ad7ad7b.tar.gz
hdf5-8194f34ef79a58dc5e57b374873be4e50ad7ad7b.tar.bz2
[svn-r24072] Merge trunk cmake changes to 1.8 branch.
Also add default switch blocks to h5import. Merge h5dump any_path option from trunk. Tested: local linux
Diffstat (limited to 'c++/examples/CMakeLists.txt')
-rw-r--r--c++/examples/CMakeLists.txt24
1 files changed, 1 insertions, 23 deletions
diff --git a/c++/examples/CMakeLists.txt b/c++/examples/CMakeLists.txt
index dd8e45d..c25b98c 100644
--- a/c++/examples/CMakeLists.txt
+++ b/c++/examples/CMakeLists.txt
@@ -29,27 +29,5 @@ FOREACH (example ${examples})
ENDFOREACH (example ${examples})
IF (BUILD_TESTING)
- # Remove any output file left over from previous test run
- ADD_TEST (
- NAME cpp_ex-clear-objects
- COMMAND ${CMAKE_COMMAND}
- -E remove
- Group.h5
- SDS.h5
- SDScompound.h5
- SDSextendible.h5
- Select.h5
- )
- IF (NOT "${last_test}" STREQUAL "")
- SET_TESTS_PROPERTIES (cpp_ex-clear-objects PROPERTIES DEPENDS ${last_test})
- ENDIF (NOT "${last_test}" STREQUAL "")
- SET (last_test "cpp_ex-clear-objects")
-
- FOREACH (example ${examples})
- ADD_TEST (NAME cpp_ex_${example} COMMAND $<TARGET_FILE:cpp_ex_${example}>)
- IF (NOT "${last_test}" STREQUAL "")
- SET_TESTS_PROPERTIES (cpp_ex_${example} PROPERTIES DEPENDS ${last_test})
- ENDIF (NOT "${last_test}" STREQUAL "")
- SET (last_test "cpp_ex_${example}")
- ENDFOREACH (example ${examples})
+ INCLUDE (CMakeTests.cmake)
ENDIF (BUILD_TESTING)