summaryrefslogtreecommitdiffstats
path: root/c++/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2013-09-30 22:00:59 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2013-09-30 22:00:59 (GMT)
commitbb084334b8603d3f78cf7294c7c7521c6bc315bb (patch)
tree4f79ee8b9beeb589daf7428d6e97ce3caa293f33 /c++/examples/CMakeLists.txt
parent497507f5a90977efe1241eae0230b830f17ecbec (diff)
downloadhdf5-bb084334b8603d3f78cf7294c7c7521c6bc315bb.zip
hdf5-bb084334b8603d3f78cf7294c7c7521c6bc315bb.tar.gz
hdf5-bb084334b8603d3f78cf7294c7c7521c6bc315bb.tar.bz2
[svn-r24232] Description:
- Merged Allen's CMake updates for the C++ tutorial examples from the trunk - Updated RELEASE.txt
Diffstat (limited to 'c++/examples/CMakeLists.txt')
-rw-r--r--c++/examples/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/c++/examples/CMakeLists.txt b/c++/examples/CMakeLists.txt
index c25b98c..c79f6c2 100644
--- a/c++/examples/CMakeLists.txt
+++ b/c++/examples/CMakeLists.txt
@@ -20,6 +20,18 @@ SET (examples
h5group
)
+SET (tutr_examples
+ h5tutr_cmprss
+ h5tutr_crtdat
+ h5tutr_crtatt
+ h5tutr_crtgrpar
+ h5tutr_crtgrp
+ h5tutr_crtgrpd
+ h5tutr_extend
+ h5tutr_rdwt
+ h5tutr_subset
+)
+
FOREACH (example ${examples})
ADD_EXECUTABLE (cpp_ex_${example} ${HDF5_CPP_EXAMPLES_SOURCE_DIR}/${example}.cpp)
TARGET_NAMING (cpp_ex_${example} ${LIB_TYPE})
@@ -28,6 +40,14 @@ FOREACH (example ${examples})
SET_TARGET_PROPERTIES (cpp_ex_${example} PROPERTIES FOLDER examples/cpp)
ENDFOREACH (example ${examples})
+FOREACH (example ${tutr_examples})
+ ADD_EXECUTABLE (cpp_ex_${example} ${HDF5_CPP_EXAMPLES_SOURCE_DIR}/${example}.cpp)
+ TARGET_NAMING (cpp_ex_${example} ${LIB_TYPE})
+ TARGET_C_PROPERTIES (cpp_ex_${example} " " " ")
+ TARGET_LINK_LIBRARIES (cpp_ex_${example} ${HDF5_CPP_LIB_TARGET} ${HDF5_LIB_TARGET})
+ SET_TARGET_PROPERTIES (cpp_ex_${example} PROPERTIES FOLDER examples/cpp)
+ENDFOREACH (example ${tutr_examples})
+
IF (BUILD_TESTING)
INCLUDE (CMakeTests.cmake)
ENDIF (BUILD_TESTING)