summaryrefslogtreecommitdiffstats
path: root/c++/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-09-09 16:31:46 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-09-09 16:31:46 (GMT)
commitff47a7df1bc78ddf36d247c76abc03e6861b1c01 (patch)
tree78b4786655f00c75616fc894deec00989bb1f724 /c++/examples/CMakeLists.txt
parentec5f5c868fb4dad3452db045c627fe258b152cd2 (diff)
downloadhdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.zip
hdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.tar.gz
hdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.tar.bz2
[svn-r19362] Move Windows specific compile and link flags to macros
Diffstat (limited to 'c++/examples/CMakeLists.txt')
-rw-r--r--c++/examples/CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/c++/examples/CMakeLists.txt b/c++/examples/CMakeLists.txt
index c5024f5..a650db5 100644
--- a/c++/examples/CMakeLists.txt
+++ b/c++/examples/CMakeLists.txt
@@ -23,16 +23,7 @@ SET (examples
FOREACH (example ${examples})
ADD_EXECUTABLE (cpp_ex_${example} ${HDF5_CPP_EXAMPLES_SOURCE_DIR}/${example}.cpp)
H5_NAMING (cpp_ex_${example})
- IF (WIN32)
- IF (MSVC)
- IF (NOT BUILD_SHARED_LIBS)
- SET_TARGET_PROPERTIES (cpp_ex_${example}
- PROPERTIES
- LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
- )
- ENDIF (NOT BUILD_SHARED_LIBS)
- ENDIF (MSVC)
- ENDIF (WIN32)
+ TARGET_WIN_PROPERTIES (cpp_ex_${example})
TARGET_LINK_LIBRARIES (cpp_ex_${example} ${HDF5_CPP_LIB_TARGET} ${HDF5_LIB_TARGET})
ADD_TEST (NAME cpp_ex_${example} COMMAND $<TARGET_FILE:cpp_ex_${example}>)