summaryrefslogtreecommitdiffstats
path: root/c++/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-09-30 17:49:05 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-09-30 17:49:05 (GMT)
commit7171c08a8895ff2b88ea088ceb5d420ea4731e45 (patch)
tree06aea0494a3d25f49163a3e36105efe4745d75dc /c++/examples/CMakeLists.txt
parent4611f95d4c8b26e5893e024b0482be1e70f05ad1 (diff)
downloadhdf5-7171c08a8895ff2b88ea088ceb5d420ea4731e45.zip
hdf5-7171c08a8895ff2b88ea088ceb5d420ea4731e45.tar.gz
hdf5-7171c08a8895ff2b88ea088ceb5d420ea4731e45.tar.bz2
[svn-r24227] Add new examples to cmake lists
Tested: local linux
Diffstat (limited to 'c++/examples/CMakeLists.txt')
-rw-r--r--c++/examples/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/c++/examples/CMakeLists.txt b/c++/examples/CMakeLists.txt
index c25b98c..c79f6c2 100644
--- a/c++/examples/CMakeLists.txt
+++ b/c++/examples/CMakeLists.txt
@@ -20,6 +20,18 @@ SET (examples
h5group
)
+SET (tutr_examples
+ h5tutr_cmprss
+ h5tutr_crtdat
+ h5tutr_crtatt
+ h5tutr_crtgrpar
+ h5tutr_crtgrp
+ h5tutr_crtgrpd
+ h5tutr_extend
+ h5tutr_rdwt
+ h5tutr_subset
+)
+
FOREACH (example ${examples})
ADD_EXECUTABLE (cpp_ex_${example} ${HDF5_CPP_EXAMPLES_SOURCE_DIR}/${example}.cpp)
TARGET_NAMING (cpp_ex_${example} ${LIB_TYPE})
@@ -28,6 +40,14 @@ FOREACH (example ${examples})
SET_TARGET_PROPERTIES (cpp_ex_${example} PROPERTIES FOLDER examples/cpp)
ENDFOREACH (example ${examples})
+FOREACH (example ${tutr_examples})
+ ADD_EXECUTABLE (cpp_ex_${example} ${HDF5_CPP_EXAMPLES_SOURCE_DIR}/${example}.cpp)
+ TARGET_NAMING (cpp_ex_${example} ${LIB_TYPE})
+ TARGET_C_PROPERTIES (cpp_ex_${example} " " " ")
+ TARGET_LINK_LIBRARIES (cpp_ex_${example} ${HDF5_CPP_LIB_TARGET} ${HDF5_LIB_TARGET})
+ SET_TARGET_PROPERTIES (cpp_ex_${example} PROPERTIES FOLDER examples/cpp)
+ENDFOREACH (example ${tutr_examples})
+
IF (BUILD_TESTING)
INCLUDE (CMakeTests.cmake)
ENDIF (BUILD_TESTING)