summaryrefslogtreecommitdiffstats
path: root/c++/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-07-04 21:25:07 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-07-04 21:25:07 (GMT)
commitc80b03cf3310823e6343f24836227e3d91a5fa53 (patch)
tree7fcd65b42144354609720f8ad91cdaad9fec4e8e /c++/examples/Makefile.am
parentddf9e4a4afc81c4be4ce38a13641ada81204b6ac (diff)
downloadhdf5-c80b03cf3310823e6343f24836227e3d91a5fa53.zip
hdf5-c80b03cf3310823e6343f24836227e3d91a5fa53.tar.gz
hdf5-c80b03cf3310823e6343f24836227e3d91a5fa53.tar.bz2
[svn-r11016] Purpose:
Bug fix Description: Added dependencies to examples Makefiles so that examples can be run in parallel. Solution: The examples directories (for C, C++, and Fortran) all have some dependencies explicitly spelled out in their Makefiles.am. This is a good short-term solution, and should prevent errors in the Daily Tests. Platforms tested: mir, modi4 (parallel and sequential)
Diffstat (limited to 'c++/examples/Makefile.am')
-rw-r--r--c++/examples/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/c++/examples/Makefile.am b/c++/examples/Makefile.am
index 671dde6..4a76380 100644
--- a/c++/examples/Makefile.am
+++ b/c++/examples/Makefile.am
@@ -36,6 +36,10 @@ EXTRA_PROG=$(TEST_PROG)
INSTALL_FILES=create.cpp readdata.cpp writedata.cpp compound.cpp \
extend_ds.cpp chunks.cpp h5group.cpp
+# Some of the examples depend on files created by running other examples
+readdata.chkexe_: create.chkexe_
+chunks.chkexe_: extend_ds.chkexe_
+
# These are the files that 'make clean' (and derivatives) will remove from this
# directory. Since automake doesn't know about the examples, we need to
# tell it to clean the example programs, too.