summaryrefslogtreecommitdiffstats
path: root/c++/examples/Makefile.am
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2013-09-28 02:36:32 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2013-09-28 02:36:32 (GMT)
commit72fcefd24f486321993f7dac729705655c93ec11 (patch)
tree00b716b58bd7c24c9fca9cfddac216e2221a7a97 /c++/examples/Makefile.am
parentcd90900d88d2baaf4ef3b4ad6aa30af64a4581cd (diff)
downloadhdf5-72fcefd24f486321993f7dac729705655c93ec11.zip
hdf5-72fcefd24f486321993f7dac729705655c93ec11.tar.gz
hdf5-72fcefd24f486321993f7dac729705655c93ec11.tar.bz2
[svn-r24212] Purpose: Added tutorial examples
Description: Merged changes from the trunk. + Revisions 24174: - Added tutorial examples that Barbara made following the C tutorial examples. They will be configured for daily test. + Revision 24195 - Improved format/comments in tutorial examples - Added them to Makefile.* and run-c++-ex.sh.in Platforms tested: SunOS 5.11 (emu) Linux/32 2.6 (jam) Linux/64 2.6 (koala)/PGI compilers Tested the examples by running the script run-c++-ex.sh
Diffstat (limited to 'c++/examples/Makefile.am')
-rw-r--r--c++/examples/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/c++/examples/Makefile.am b/c++/examples/Makefile.am
index cd9a9f6..f479776 100644
--- a/c++/examples/Makefile.am
+++ b/c++/examples/Makefile.am
@@ -23,12 +23,18 @@ include $(top_srcdir)/config/commence.am
# These are the programs that 'make all' or 'make prog' will build and
# which 'make check' will run. List them in the order they should be run.
-EXAMPLE_PROG=create readdata writedata compound extend_ds chunks h5group
+EXAMPLE_PROG=create readdata writedata compound extend_ds chunks h5group \
+ h5tutr_cmprss h5tutr_crtatt h5tutr_crtdat h5tutr_crtgrpar \
+ h5tutr_crtgrp h5tutr_crtgrpd h5tutr_extend h5tutr_rdwt \
+ h5tutr_subset
TEST_SCRIPT=testh5c++.sh
# These are the example files to be installed
INSTALL_FILES=create.cpp readdata.cpp writedata.cpp compound.cpp \
- extend_ds.cpp chunks.cpp h5group.cpp
+ extend_ds.cpp chunks.cpp h5group.cpp \
+ h5tutr_cmprss.cpp h5tutr_crtatt.cpp h5tutr_crtdat.cpp \
+ h5tutr_crtgrpar.cpp h5tutr_crtgrp.cpp h5tutr_crtgrpd.cpp \
+ h5tutr_extend.cpp h5tutr_rdwt.cpp h5tutr_subset.cpp
INSTALL_SCRIPT_FILES = run-c++-ex.sh
# Some of the examples depend on files created by running other examples
@@ -58,5 +64,15 @@ extend_ds: $(srcdir)/extend_ds.cpp
chunks: $(srcdir)/chunks.cpp
h5group: $(srcdir)/h5group.cpp
+h5tutr_cmprss: $(srcdir)/h5tutr_cmprss.cpp
+h5tutr_crtatt: $(srcdir)/h5tutr_crtatt.cpp
+h5tutr_crtdat: $(srcdir)/h5tutr_crtdat.cpp
+h5tutr_crtgrpar: $(srcdir)/h5tutr_crtgrpar.cpp
+h5tutr_crtgrp: $(srcdir)/h5tutr_crtgrp.cpp
+h5tutr_crtgrpd: $(srcdir)/h5tutr_crtgrpd.cpp
+h5tutr_extend: $(srcdir)/h5tutr_extend.cpp
+h5tutr_rdwt: $(srcdir)/h5tutr_rdwt.cpp
+h5tutr_subset: $(srcdir)/h5tutr_subset.cpp
+
include $(top_srcdir)/config/examples.am
include $(top_srcdir)/config/conclude.am