summaryrefslogtreecommitdiffstats
path: root/c++/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-08-02 17:59:03 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-08-02 17:59:03 (GMT)
commite75a185ecaab4f55afaae0855a40770a300a2cc0 (patch)
treeaa938d97ec85dea32adfad0005fbaac5ef9edb6f /c++/examples/Makefile.am
parent7def00050fd07e93bee65e2e8ad2fac0001cc05e (diff)
downloadhdf5-e75a185ecaab4f55afaae0855a40770a300a2cc0.zip
hdf5-e75a185ecaab4f55afaae0855a40770a300a2cc0.tar.gz
hdf5-e75a185ecaab4f55afaae0855a40770a300a2cc0.tar.bz2
[svn-r11185] Purpose:
Makefile feature Description: 'make check-clean' now cleans *.h5 files created by tests as well as .log and .chkexe files. Solution: check-clean is now a separate target in its own right, which cleans less than mostlyclean (check-clean < mostlyclean < clean < distclean). Platforms tested: mir, heping, modi4 (serial and parallel)
Diffstat (limited to 'c++/examples/Makefile.am')
-rw-r--r--c++/examples/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/c++/examples/Makefile.am b/c++/examples/Makefile.am
index f1664ff..995964b 100644
--- a/c++/examples/Makefile.am
+++ b/c++/examples/Makefile.am
@@ -43,7 +43,8 @@ chunks.chkexe_: extend_ds.chkexe_
# These are the files that 'make clean' (and derivatives) will remove from this
# directory. Since automake doesn't know about the examples, we need to
# tell it to clean the example programs, too.
-MOSTLYCLEANFILES+=*.h5 $(EXTRA_PROG:=.o)
+CHECK_CLEANFILES+=*.h5
+MOSTLYCLEANFILES=$(EXTRA_PROG:=.o)
CLEANFILES=$(EXTRA_PROG)
# Tell conclude.am that these are C++ tests.