summaryrefslogtreecommitdiffstats
path: root/c++/examples/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2015-04-29 07:22:43 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2015-04-29 07:22:43 (GMT)
commit056ffa6341ab4ea929066ee896a246c064a1d0cd (patch)
tree33a95c314585823da59a58a738a3e5d7c4b4d1c0 /c++/examples/Makefile.am
parent65ba755e8a744baa2c657eec6e0f4a1d9b502a08 (diff)
downloadhdf5-056ffa6341ab4ea929066ee896a246c064a1d0cd.zip
hdf5-056ffa6341ab4ea929066ee896a246c064a1d0cd.tar.gz
hdf5-056ffa6341ab4ea929066ee896a246c064a1d0cd.tar.bz2
[svn-r26963] HDFFV-9298: make uninstall generated "test: argument expected" lines
The error is that $EXAMPLETOPDIR is used without setting a value first. Solution is to set them with the proper values. Tested: jam only to confirm the error no longer exists.
Diffstat (limited to 'c++/examples/Makefile.am')
-rw-r--r--c++/examples/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/c++/examples/Makefile.am b/c++/examples/Makefile.am
index 5bb8d59..2408217 100644
--- a/c++/examples/Makefile.am
+++ b/c++/examples/Makefile.am
@@ -42,8 +42,8 @@ INSTALL_FILES=create.cpp readdata.cpp writedata.cpp compound.cpp \
# Some of the examples depend on files created by running other examples
readdata.chkexe_: create.chkexe_
chunks.chkexe_: extend_ds.chkexe_
-h5tutr_rdwt.chkexe_: h5tutrcrtdat.chkexe
-h5tutrcrtatt.chkexe_: h5tutrcrtdat.chkexe
+h5tutr_rdwt.chkexe_: h5tutr_crtdat.chkexe
+h5tutrcrtatt.chkexe_: h5tutr_crtdat.chkexe
h5tutr_crtgrpd.chkexe_: h5tutr_crtgrpar.chkexe
# Tell conclude.am that these are C++ tests.
@@ -52,6 +52,7 @@ CXX_API=yes
# Where to install examples
# Note: no '/' after DESTDIR. Explanation in commence.am
EXAMPLEDIR=${DESTDIR}$(exec_prefix)/share/hdf5_examples/c++
+EXAMPLETOPDIR=${DESTDIR}$(exec_prefix)/share/hdf5_examples
# How to build programs using h5c++
$(EXTRA_PROG): $(H5CPP)