summaryrefslogtreecommitdiffstats
path: root/c++/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-12-09 20:59:11 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-12-09 20:59:11 (GMT)
commitb1fd3f565750a18246239cdac50e433d6d668524 (patch)
treef09179e1fb2a04e01983c85f9a3873c159fefda7 /c++/examples/Makefile.am
parent9124030f911f002bd49ec8bccd4c051df410cc72 (diff)
downloadhdf5-b1fd3f565750a18246239cdac50e433d6d668524.zip
hdf5-b1fd3f565750a18246239cdac50e433d6d668524.tar.gz
hdf5-b1fd3f565750a18246239cdac50e433d6d668524.tar.bz2
[svn-r11780] Purpose:
Added high-level example directories Description: Refactored common code out of examples Makefiles.am, added high-level example directories, added packet table examples. Solution: Examples now draw from a common config/examples.am file, which contains rules for installing, uninstalling, and cleaning examples. High-level example directories are mostly empty, except for the C and C++ packet table tests. Platforms tested: mir, sleipnir, copper, shanti
Diffstat (limited to 'c++/examples/Makefile.am')
-rw-r--r--c++/examples/Makefile.am49
1 files changed, 2 insertions, 47 deletions
diff --git a/c++/examples/Makefile.am b/c++/examples/Makefile.am
index e82c3cd..f60b6d7 100644
--- a/c++/examples/Makefile.am
+++ b/c++/examples/Makefile.am
@@ -24,11 +24,6 @@ include $(top_srcdir)/config/commence.am
# which 'make check' will run. List them in the order they should be run.
TEST_PROG=create readdata writedata compound extend_ds chunks h5group
-EXAMPLE_PROG=$(TEST_PROG)
-
-# Tell conclude.in when to build the examples
-EXTRA_PROG=$(TEST_PROG)
-
# These are the example files to be installed
INSTALL_FILES=create.cpp readdata.cpp writedata.cpp compound.cpp \
extend_ds.cpp chunks.cpp h5group.cpp
@@ -37,53 +32,12 @@ INSTALL_FILES=create.cpp readdata.cpp writedata.cpp compound.cpp \
readdata.chkexe_: create.chkexe_
chunks.chkexe_: extend_ds.chkexe_
-# These are the files that 'make clean' (and derivatives) will remove from this
-# directory. Since automake doesn't know about the examples, we need to
-# tell it to clean the example programs, too.
-CHECK_CLEANFILES+=*.h5
-MOSTLYCLEANFILES=$(EXTRA_PROG:=.o)
-CLEANFILES=$(EXTRA_PROG)
-
# Tell conclude.am that these are C++ tests.
HDF_CXX=yes
-# How to install examples
+# Where to install examples
EXAMPLEDIR=$(docdir)/hdf5/examples/c++
-$(EXAMPLEDIR):
- -$(top_srcdir)/bin/mkdirs $@
-
-install-data-local:
- @$(MAKE) install-examples
-uninstall-local:
- @$(MAKE) uninstall-examples
-
-# Some C++ compilers/linkers will create a directory named ii_files,
-# which should be cleaned.
-mostlyclean-local:
- if test -d ii_files; then \
- $(RM) -rf ii_files; \
- fi
-
-# Install source files, which are the examples with .cpp suffixes. Do the same
-# for uninstall.
-install-examples: $(EXAMPLEDIR)
- @for f in X $(INSTALL_FILES); do \
- if test $$f != X; then \
- (set -x; $(INSTALL_DATA) $(top_srcdir)/c++/examples/$$f $(EXAMPLEDIR)/. || exit 1);\
- fi; \
- done
-
-uninstall-examples:
- @if test -n "$(INSTALL_FILES)" -a -d $(EXAMPLEDIR); then \
- set -x; cd $(EXAMPLEDIR) && $(RM) $(INSTALL_FILES).cpp; \
- fi
-
-check-install:
- @$(MAKE) $(AM_MAKEFLAGS) installcheck
-installcheck-local:
- @$(MAKE) $(AM_MAKEFLAGS) check
-
# How to build programs using h5c++
$(EXTRA_PROG): $(LIBHDF5) $(LIBH5CPP)
$(H5CPP) $(CPPFLAGS) -o $@ $(srcdir)/$@.cpp
@@ -100,4 +54,5 @@ extend_ds: $(srcdir)/extend_ds.cpp
chunks: $(srcdir)/chunks.cpp
h5group: $(srcdir)/h5group.cpp
+include $(top_srcdir)/config/examples.am
include $(top_srcdir)/config/conclude.am