summaryrefslogtreecommitdiffstats
path: root/c++/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-08-01 22:22:55 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-08-01 22:22:55 (GMT)
commitc63ef2cba28df827eb090a019284c7cd8c2982af (patch)
tree134ff7254d8ee7b1c6f7fa3eabc509528899d68d /c++/examples/Makefile.am
parentf2240792704b74fc288b4e4a570509c4afe4a34e (diff)
downloadhdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.zip
hdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.tar.gz
hdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.tar.bz2
[svn-r11179] Purpose:
Feature: check-clean target Description: 'make check-clean' cleans up output files from tests. Solution: Tests create foo.chkexe and foo.log files. Scripts create foo.chksh and foo.logsh files. 'make check-clean' will clean these files up so that the tests can be re-run. Also suppressed some not-very-useful output of Makefiles when it would echo commands. Platforms tested: mir, sleipnir, modi4 Misc. update:
Diffstat (limited to 'c++/examples/Makefile.am')
-rw-r--r--c++/examples/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/c++/examples/Makefile.am b/c++/examples/Makefile.am
index 23757b3..f1664ff 100644
--- a/c++/examples/Makefile.am
+++ b/c++/examples/Makefile.am
@@ -56,9 +56,9 @@ $(EXAMPLEDIR):
-$(top_srcdir)/bin/mkdirs $@
install-data-local:
- $(MAKE) install-examples
+ @$(MAKE) install-examples
uninstall-local:
- $(MAKE) uninstall-examples
+ @$(MAKE) uninstall-examples
# Install source files, which are the examples with .cpp suffixes. Do the same
# for uninstall.
@@ -75,9 +75,9 @@ uninstall-examples:
fi
check-install:
- $(MAKE) installcheck
+ @$(MAKE) $(AM_MAKEFLAGS) installcheck
installcheck-local:
- $(MAKE) check
+ @$(MAKE) $(AM_MAKEFLAGS) check
# How to build programs using h5c++
$(EXTRA_PROG): $(H5CPP) $(LIBHDF5) $(LIBH5CPP)