summaryrefslogtreecommitdiffstats
path: root/c++/examples/Makefile.am
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2020-06-29 16:53:55 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2020-06-29 16:53:55 (GMT)
commit785a1cef0c2ea2d1a179d86e34117ffd73aaa70d (patch)
tree328dac1fd1adf20d4c2077fa15da7327a39817f2 /c++/examples/Makefile.am
parent7a4d7da14a745333c4e8f3955a0afd9db70969c0 (diff)
parent30776671fb0a27a98b0640aa968f850241a862ce (diff)
downloadhdf5-785a1cef0c2ea2d1a179d86e34117ffd73aaa70d.zip
hdf5-785a1cef0c2ea2d1a179d86e34117ffd73aaa70d.tar.gz
hdf5-785a1cef0c2ea2d1a179d86e34117ffd73aaa70d.tar.bz2
Merging in latest from upstream (HDFFV/hdf5:refs/heads/develop)
* commit '30776671fb0a27a98b0640aa968f850241a862ce': (31 commits) * Fix intermittent error with Splitter VFD. Mismatch in time of test file creation was creating false negatives. Added note for HDFFV-10591. Fix HDFFV-10591 Reduce overhead for H5open, which is involved in the public symbols like H5T_NATIVE_INT, etc. Remove unnecessary version conditions for Clang compilers. Fix for HDFFV-10961: Couple changes to the tests' usage output files for h5clear. Fix for HDFFV-10961: add description to usage for --increment option. Add c++ to --enable-sanitize-checks option. Remove duplicate entries in MANIFEST. Make changes to CMake CompilerFlags.cmake files so extra flags are loaded for non-GNU compilers. Fix MANIFEST Add tests for all version to H5_NO_DEPRECATED_SYMBOLS section and to section for current version, with and without default API version flags. HDFFV-11000: update-testh5cc.sh.in to test sample versioned functions in HDF5 1.10, 1.12 and develop. Remember the info for the last ID looked up for a given ID type. Eliminate allocating file & memory offset & length arrays when performing I/O on a single element. Update new clang files to not pick up clang as vendor for pgCC. Add new files to MANIFEST Temporary demotion of 2 -Werror warning flags that fail on macos 10.12 Remove Production flag unknown to Apple clang. Remove redundant metadata cache tagging from some low-level internal chunk functions. The metadata cache tagging has already been done by routines further up the call stack. Clean up code to get clang version in config/linux-gnulibc1 Minor normalizations with HDF5 1.10. Add flags from config/clang-warnings/*general files to H5 C and CXX flags for all versions of Clang and Clang++ compilers. Switched from cut to awk in testcheck_version.sh.in to avoid dependence on tab vs. " " in version definitions in H5public.h. ...
Diffstat (limited to 'c++/examples/Makefile.am')
-rw-r--r--c++/examples/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/c++/examples/Makefile.am b/c++/examples/Makefile.am
index 0648504..cbec8f8 100644
--- a/c++/examples/Makefile.am
+++ b/c++/examples/Makefile.am
@@ -49,8 +49,8 @@ CXX_API=yes
# Where to install examples
# Note: no '/' after DESTDIR. Explanation in commence.am
-EXAMPLEDIR=$(examplesdir)/c++
-EXAMPLETOPDIR=$(examplesdir)
+EXAMPLEDIR=${DESTDIR}$(examplesdir)/c++
+EXAMPLETOPDIR=${DESTDIR}$(examplesdir)
# How to build programs using h5c++
$(EXTRA_PROG): $(H5CPP)