summaryrefslogtreecommitdiffstats
path: root/c++/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-05-09 18:45:44 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-05-09 18:45:44 (GMT)
commitdcc66a4f157ace0858b788228550f3e104df3242 (patch)
treee60eaa27df6d6bc80a32d6a73d329c41c423eb54 /c++/src/CMakeLists.txt
parent7aeebec9463d18c3040ba7fa37464c00b64ab75e (diff)
parentd6ea76ac002cd8483ba8a6aaf55bbce5ed552937 (diff)
downloadhdf5-dcc66a4f157ace0858b788228550f3e104df3242.zip
hdf5-dcc66a4f157ace0858b788228550f3e104df3242.tar.gz
hdf5-dcc66a4f157ace0858b788228550f3e104df3242.tar.bz2
Merge pull request #1049 in HDFFV/hdf5 from ~BYRN/hdf5_adb:develop to develop
* commit 'd6ea76ac002cd8483ba8a6aaf55bbce5ed552937': GGC requires attribute before function Correct COMPILE defs usage Add missing module_dir property
Diffstat (limited to 'c++/src/CMakeLists.txt')
-rw-r--r--c++/src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/c++/src/CMakeLists.txt b/c++/src/CMakeLists.txt
index 8226d16..cf7a8a5 100644
--- a/c++/src/CMakeLists.txt
+++ b/c++/src/CMakeLists.txt
@@ -88,7 +88,7 @@ target_include_directories(${HDF5_CPP_LIB_TARGET}
INTERFACE "$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/include>"
)
target_compile_definitions(${HDF5_CPP_LIB_TARGET}
- PRIVATE $<$<BOOL:${HDF5_ENABLE_PARALLEL}>:"-DMPICH_SKIP_MPICXX;-DMPICH_IGNORE_CXX_SEEK"># Parallel/MPI, prevent spurious cpp/cxx warnings
+ PRIVATE $<$<BOOL:${HDF5_ENABLE_PARALLEL}>:MPICH_SKIP_MPICXX;MPICH_IGNORE_CXX_SEEK># Parallel/MPI, prevent spurious cpp/cxx warnings
)
TARGET_C_PROPERTIES (${HDF5_CPP_LIB_TARGET} STATIC)
target_link_libraries (${HDF5_CPP_LIB_TARGET} PUBLIC ${HDF5_LIB_TARGET})
@@ -105,7 +105,7 @@ if (BUILD_SHARED_LIBS)
)
target_compile_definitions(${HDF5_CPP_LIBSH_TARGET}
PUBLIC "H5_BUILT_AS_DYNAMIC_LIB"
- PRIVATE $<$<BOOL:${HDF5_ENABLE_PARALLEL}>:"-DMPICH_SKIP_MPICXX;-DMPICH_IGNORE_CXX_SEEK"># Parallel/MPI, prevent spurious cpp/cxx warnings
+ PRIVATE $<$<BOOL:${HDF5_ENABLE_PARALLEL}>:MPICH_SKIP_MPICXX;MPICH_IGNORE_CXX_SEEK># Parallel/MPI, prevent spurious cpp/cxx warnings
)
TARGET_C_PROPERTIES (${HDF5_CPP_LIBSH_TARGET} SHARED)
target_link_libraries (${HDF5_CPP_LIBSH_TARGET} PUBLIC ${HDF5_LIBSH_TARGET})