summaryrefslogtreecommitdiffstats
path: root/c++/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2018-03-12 16:45:23 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2018-03-12 16:45:23 (GMT)
commit64565f9771a50138e77a806d7ab330e3919c1847 (patch)
tree479e75b5b1e94f07f388e22992b8c51bf8768a62 /c++/src/CMakeLists.txt
parent0684235b36bb58edddd8ad4356077fa208944ef6 (diff)
parentb638bbd74b79f935a43aa6a804492e035ec315f6 (diff)
downloadhdf5-64565f9771a50138e77a806d7ab330e3919c1847.zip
hdf5-64565f9771a50138e77a806d7ab330e3919c1847.tar.gz
hdf5-64565f9771a50138e77a806d7ab330e3919c1847.tar.bz2
Merge pull request #936 in HDFFV/hdf5 from ~BMRIBLER/hdf5_bmr_cpp3:develop to develop
Modified 43158f3bb352f374c31556a5d0dc463a09e0b32e and additional wrappers. * commit 'b638bbd74b79f935a43aa6a804492e035ec315f6': Code improvement Description: - Removed memory leaks caused by accidentally invoking p_get_member_type - Added the call to test_lcpl, missed previously Platforms tested: Linux/64 (jelly) Linux/ppc64 (ostrich) Darwin (osx1010test) Updated RELEASE.txt Description: - Wrappers for H5Lcreate_soft, H5Lcreate_hard, H5Lcopy, H5Lmove, H5Ldelete, and H5Lget_info - Class LinkCreatPropList - Fixed typo in source file Platforms tested: Linux/64 (jelly) Updated for H5LcreatProp.[h,cpp] Updated MANIFEST for H5LcreatProp.[h,cpp] HDFFV-10149 continued Description: - Moved the new wrappers committed on Mar 9: 43158f3bb352f374c31556a5d0dc463a09e0b32e to H5Location and renamed some of them for overloading. This is because the loc_id in the C APIs can be file, group, dataset, named datatype, and attribute. Previous implementation was wrong following some inaccurate C API reference manual.
Diffstat (limited to 'c++/src/CMakeLists.txt')
-rw-r--r--c++/src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/c++/src/CMakeLists.txt b/c++/src/CMakeLists.txt
index d24a3a6..1136d6a 100644
--- a/c++/src/CMakeLists.txt
+++ b/c++/src/CMakeLists.txt
@@ -33,6 +33,7 @@ set (CPP_SOURCES
${HDF5_CPP_SRC_SOURCE_DIR}/H5IdComponent.cpp
${HDF5_CPP_SRC_SOURCE_DIR}/H5IntType.cpp
${HDF5_CPP_SRC_SOURCE_DIR}/H5LaccProp.cpp
+ ${HDF5_CPP_SRC_SOURCE_DIR}/H5LcreatProp.cpp
${HDF5_CPP_SRC_SOURCE_DIR}/H5Library.cpp
${HDF5_CPP_SRC_SOURCE_DIR}/H5Location.cpp
${HDF5_CPP_SRC_SOURCE_DIR}/H5Object.cpp
@@ -70,6 +71,7 @@ set (CPP_HDRS
${HDF5_CPP_SRC_SOURCE_DIR}/H5Include.h
${HDF5_CPP_SRC_SOURCE_DIR}/H5IntType.h
${HDF5_CPP_SRC_SOURCE_DIR}/H5LaccProp.h
+ ${HDF5_CPP_SRC_SOURCE_DIR}/H5LcreatProp.h
${HDF5_CPP_SRC_SOURCE_DIR}/H5Library.h
${HDF5_CPP_SRC_SOURCE_DIR}/H5Location.h
${HDF5_CPP_SRC_SOURCE_DIR}/H5Object.h